WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Emails not Sent (5 posts)

  1. sam.boychuk@booktrack.co
    Member
    Posted 1 year ago #

    Uh, ok. So I can't send any emails. My server provider told me that the SMTP server has to be set to theirs. In other applications in WordPress the plugin works fine when the SMTP server is set to the host provider.

    How can I set the SMTP server. I have a plugin called Change SMTP installed, but it does not seem to affect Subscribe2. I don't mind getting in the code, tell me where

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @Sam,

    I haven't been able to find a plugin called Change SMTP but I know that WP Mail SMTP and Configure SMTP both work fine with Subscribe2 and allow configuration of an SMTP outgoing email server.

    If this still doesn't work it is most likely down to a sending restriction on the SMTP server related to either the number of recipients per email message or to the number of email messages allowed per unit time.

    The former of these can be set in Subscribe2->Settings by changing the setting where it says Number of Recipients per Email. The number of emails per unit time can be fixed with a plugin that throttles the sending of emails, something like WordPress Mail Queue.

  3. sam.boychuk@booktrack.co
    Member
    Posted 1 year ago #

    Thanks Mattyrob,

    Uh well, I checked my spam folder and I have a whole stack of emails saying:

    <blog@----.net>: host smtp3.---.net[207.5.74.239]
        said: 550 5.1.1 <blog@----.net>: Recipient address
        rejected: User unknown in relay recipient table (in reply to RCPT TO
        command)

    and

    <blogupdates@---.com>: host aspmx.l.google.com[173.194.79.26] said:
        550-5.1.1 The email account that you tried to reach does not exist. Please
        try 550-5.1.1 double-checking the recipient's email address for typos or
        550-5.1.1 unnecessary spaces. Learn more at 550 5.1.1
        http://support.google.com/mail/bin/answer.py?answer=6596 mo5si502551pbc.88
        (in reply to RCPT TO command)

    and the like. Let me deduce if I may. Subscribe2 attempts to send the email to the From address to hide the recipient address. Then when it does, because the FROM email address that i used does not exist (thought catch-all would grab it) it fails to send the email and the actual recipient - for some reason - receives a bounce error msg.

    Would that sound correct? It isn't working because the from email is not legitimate?

    Thanks - Sam

  4. sam.boychuk@booktrack.co
    Member
    Posted 1 year ago #

    I did mean Configure SMTP - not Change SMTP. My bad.

  5. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @Sam,

    Having Subscribe2 send from a legitimate email address that actually exists and is on the same domain as your blog is highly recommended and is also the biggest reason by far why emails don't get sent.

    Create an email address for you blog if you need to, then create a new Admin level user in your WordPress blog (at Users->Add New) using this email address. Finally, in Subscribe2->Settings choose this user account as your email sender and then try again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.