WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] email notification is not being sent (6 posts)

  1. ABID KHAN
    Member
    Posted 1 year ago #

    hi,

    I've installed subscribe2 so that when I make new post, it is automatically sent to those who made account in my website but I made posts and no notification is sent to them. Is there any conflict with some other plugin? or any other problem?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @Abid,

    If I got paid a dollar a minute for the amount of time I spend answering this question I'd be very rich indeed! :)

    Failed emails can be down to any number of reasons from Subscribe2 settings to server configuration and hosting provider limitations on your domain.

    Have a look in the FAQs and start where it says "Some or all email notifications fail to send, why?". I suspect something in there will point you in the right direction.

  3. ABID KHAN
    Member
    Posted 1 year ago #

    I had been sending before in the start. After that I didn't confirmed that whether it is sending now or not. I've installed/deleted many plugins after that. yesterday I checked whether it is sending notification of new post or not by making an account by another email in my website and found that it is not sending new post notification. I guess that it has some conflict with some plugin. I thought you might have any such knowledge about conflicting plugin.

  4. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @Abid,

    Well, there's a lot more details in your second post that changes things quite dramatically, it might have been useful to know all of that in the first place.

    There are some plugin conflicts mainly with plugins that alter the core wp_mail() function or that call the pluggable.php file early without a hook. Also some caching plugins sometimes have an impact.

    Unfortunately, because plugins are so frequently updated or conversely sometimes not maintained at all, it is hard to keep track.

    My best advise would be to disable all other plugins except Subscribe2 and see if you can get it working again. If you can then enable plugins a few at a time and try again until something breaks and then you can narrow it down to a plugin conflict.

  5. ABID KHAN
    Member
    Posted 1 year ago #

    Ok nice instruction. But please can you guide me a bit that do I have to make new post to check whether it is sending message or not? It will be very difficult for me.

  6. mattyrob
    Member
    Plugin Author

    Posted 1 year ago #

    @Abid,

    When you go to Subscribe2->Settings there is a Send Preview Email button. This will send an example email based on the latest post to the logged in users email address only.

    If there is a plugin conflict affecting the code it would be highly likely that this will fail to work. However, it will probably still work if the issue is not conflict related (so if it's to do with a server restriction for example). Try sending a preview first without disabling anything. If that works it's probably not a conflict in the first place.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic