WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Database warning (4 posts)

  1. lenemaria@violabrun.dk
    Member
    Posted 1 year ago #

    Hi. I get this warning when trying to install.

    'Warning: require_once(/customers/f/5/0/kirstinestubbeteglbjaerg.com/httpd.www/wp-content/plugins/follow/classes/class-s2-core.php): failed to open stream: No such file or directory in /customers/f/5/0/kirstinestubbeteglbjaerg.com/httpd.www/wp-content/plugins/subscribe2/subscribe2.php on line 57 Fatal error: require_once(): Failed opening required '/customers/f/5/0/kirstinestubbeteglbjaerg.com/httpd.www/wp-content/plugins/follow/classes/class-s2-core.php' (include_path='.:/usr/share/php') in /customers/f/5/0/kirstinestubbeteglbjaerg.com/httpd.www/wp-content/plugins/subscribe2/subscribe2.php on line 57'

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @lenemaria,

    Once you know how to read error messages like tey they become a lot less scary.

    The entire path to a file is in that text block 4 times over, if I remove it you are left with this:

    Warning: require_once: failed to open stream: No such file or directory in subscribe2.php on line 57 Fatal error: require_once(): Failed opening required class-s2-core.phpsubscribe2.php on line 57

    Okay so that looks a lot neater now, firstly it's giving a 'warning' saying on line 57 of the file subscribe2.php a file is being called that does not exist, next it pretty much repeats the error but this time reporting a fatal error rather than a warning.

    So, this latter part is telling you that the missing file is vital and without it being there the code cannot run.

    What does all of that mean in simple terms then - well, as you might have figured out by now, it means there is at least one file missing in your install. You need to install the plugin completely and try again making sure to include all the necessary files.

  3. lenemaria@violabrun.dk
    Member
    Posted 1 year ago #

    Thank you for clarifying! But the message I get when installing is "That the plugin was successfully installed" and then the error message shows up when I try to activate the plugin. Could it be that I'm running a Danish version of WordPress?

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @lenemaria,

    I don't think your local language should make any difference but as I'm an English speaker I really can't be sure.

    Try Deleting it and re-installing, if it fails again download the plugin zip and install it by "Upload" from the Plugins->Add New page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.