WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Confirmation page for email sign up (4 posts)

  1. Benjammin854
    Member
    Posted 1 year ago #

    I am trying to create a separate thank you page that subscribers land on after entering their email address in my Subscribe2 widget. How would I create a thank you page using WordPress that only is accessible through
    the Subscribe2 widget?

    I know that in the Appearance --> Widgets section of WordPress I can select the pages the visitor lands on after subscribing, but these are the pages that are already featured as menu items on my home page. (e.g. "About the Author", "About this Blog"). Is it possible to send the subscriber to a Page that I create that is not a featured page on my homepage? If so, how do I accomplish this.

    Thank you.

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Benjammin854,

    You need to create the Thank You page in the usual way and then find a way to exclude it from your home page.

    Most themes use wp_list_pages() to list the pages on the homepage, that function has an exclude parameter so you would need to add that into the function and exclude the correct page id. Maybe something like this:
    <?php wp_list_pages('exclude=n' ); ?>
    Where 'n' is the ID number of the Thank You page.

  3. Benjammin854
    Member
    Posted 1 year ago #

    Thanks for your help...I wasn't able to find the pages in which that those parameters were listed. All the files available in the editor for the theme are php files. I looked in everyone of them for "wp_list_pages" and could find a thing.

    Nonetheless, I do believe I found the easiest way to do it. I downloaded a plugin called "Exclude Pages" and it now allows me to create public pages and not have them be included on the home menu. From there I created my Thank You page and did just that. Works like a charm now!

    Cheers!

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @Benjammin854,

    Maybe your theme does it differently but at least you have a solution. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic