WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
Can't Delete Custom Field named "s2mail" (7 posts)

  1. rokksie
    Member
    Posted 2 years ago #

    Hi! Every new post I create automatically gets a custom field named s2mail. It shows up under my posts in the meta section either as s2mail:yes or s2mail:no. I guess it has something to do with Subscribe2 Notification Override. I just know it's driving me crazy! Is there a fix to this so this custom field will not show up anymore?

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @rokksie,

    Where are you seeing this? On the front of you site or in the admin area? If admin you can hide it using the "screen options" button in the menus at the top.

  3. rokksie
    Member
    Posted 2 years ago #

    @MattyRob

    Hi! Thank you for your reply! I am actually seeing it on the front of my site. For every post I create. :'(

    Here is a link to a screen capture of what is happening with every post:

    http://rokkstarrcreative.com/wp_s2mail_capture.JPG

    And depending on if I override notifications it will either say S2MAIL: YES or S2MAIL:NO But no matter what is chosen the S2MAIL custom field shows up.

  4. rokksie
    Member
    Posted 2 years ago #

    Oh and.. I am already using a custom field called Image Set.. However.. in the drop down list for when I am going to post, s2mail has automatically been added to the custom field drop down list as an option. I don't know why that happens. When I just choose my Image Set custom field everything seems ok until I click post.. And once posted, s2mail field is just automatically added and displays for each post. I cant even delete it from the post because even when I do, and hit "update", it is right back there. LOL.

  5. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @rokksie,

    I see what you mean - are you using a feature of the theme or a plugin to display the post meta information? It's that code that needs editing.

  6. rokksie
    Member
    Posted 2 years ago #

    @MattyRob

    I am still trying to figure this out.. :'( I am using the Genesis Framework so I don't know if that has anything to do with it. Even if I can just figure out how to just display the original custom field which is "Image Set" and ignore the "s2mail" field that keeps showing.

  7. rokksie
    Member
    Posted 2 years ago #

    @MattyRob

    Ok! I found the answer and it did the trick.. This is what I found in the WordPress forums:

    http://wordpress.org/support/topic/exclude-individual-custom-fields-from-single?replies=5

    I replaced <?php the_meta(); ?> with the code mentioned in the above link within my genesis_post_content hook and it worked! The s2mail field is no longer showing. It has been excluded out! Yaaaay!

    Thank you MattyRob though for replying to me! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic