WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Bug in 8.0? (26 posts)

  1. ghostrose333
    Member
    Posted 2 years ago #

    There appears to be a bug in the new 8.0 update. When I updated the plugin, my page would not load and I get the following message from Firefox.

    "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."

    I do not have cookies disabled. The only way to get the page back was to manually uninstall the plugin. 7.2 works fine.

    Just a heads up, thanks for the great plugin :)

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattbailey
    Member
    Posted 2 years ago #

    I've just had exactly the same experience.

    An update to fix this would be great.

    Also love the plugin!

  3. Ed
    Member
    Posted 2 years ago #

    Ah glad someone else has reported it, getting the same on Multi-Site. Rolled back to 7.2 for now.

  4. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    I fine it practically impossible to test on MultiSite installs so my apologies for this bug. If anyone is prepared to allow me access to your site to debug this issue please can you contact me here.

  5. Ed
    Member
    Posted 2 years ago #

    Check email.

  6. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @Ed,

    I'll be checking my email from home tonight - about 6 hours from now. Can't check it while I'm at work.

  7. Ed
    Member
    Posted 2 years ago #

    No problem, just give me a shout - I'll be on most of the evening.

  8. Andrey
    Member
    Posted 2 years ago #

    I'd like to roll back to v.7.2 but cannot find where to download it now.
    Can somebody help?

  9. Ed
    Member
    Posted 2 years ago #

    http://wordpress.org/extend/plugins/subscribe2/download/

    They're always in the Other Version section.

  10. Andrey
    Member
    Posted 2 years ago #

    Oops. Sorry for stupid question :)
    Thank you Ed!

  11. azchipka
    Member
    Posted 2 years ago #

    Same problem here as well

  12. bsweeney
    Member
    Posted 2 years ago #

    I'm having the same problem. A temporary work-around (besides downgrading to 7.2) is to comment out lines 83-84, 87-88. These lines appear to be responsible for the infinite redirect loop.

    Also of note, if you attempt to access the implicated pages (/wp-admin/users.php?page=s2_users or /wp-admin/profile.php?page=s2_users) after commenting those lines you get the following error:

    You do not have sufficient permissions to access this page.

    And, finally, the following page doesn't include the WP bar at the top of the page. Premature end of script maybe?
    /wp-admin/admin.php?page=s2

  13. ulyssesr
    Member
    Posted 2 years ago #

    Yea, there is a bug with the latest version. I noticed that I could not login to the Dashboard after I updated to the latest version of the Subscribe2 plugin. WordPress search also doesn't seem to be doing anything. I noticed that in both occasion, my blog redirects everything back to my home page. I ended up using FTP and deleting the Subscribe2 plugin for now, until a fix is available.

  14. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    First I'd like to thank Ed for getting in touch and allowing me to bug hunt using his web space - without that fixing this would have taken ages.

    I've just committed some changes to the code and there is now a development version 8.1 ready for download here:
    http://downloads.wordpress.org/plugin/subscribe2.zip

    And I think it fixes quite a few bugs I found including the huge redirect issue - after fixing that though I found plenty more. Please report any further issues as fully as you can here on this thread.

  15. nadaoneal
    Member
    Posted 2 years ago #

    This looks good to me so far (WP 3.3.1 multisite). Thanks for your quick fix.

  16. Ken of Kentropolis
    Member
    Posted 2 years ago #

    Much thanks. I will install and if it works, will note on the plugins page that it works.

    Update: It works. Thank you for supporting your software ... I'm sending a few buck doantion and encourage others to do so as well.

  17. jugoretz
    Member
    Posted 2 years ago #

    Works for me, too. Add my thanks and I'm donating, too. Great work, MattyRob.

  18. mattbailey
    Member
    Posted 2 years ago #

    Update working for me too.

    Thanks so much for such a quick fix, and a great plugin!

  19. ulyssesr
    Member
    Posted 2 years ago #

    Thanks for the quick reply. The update seems to be working, although I haven't posted anything yet. Thank you once again. At least, the redirect issue is gone.

  20. Andrey
    Member
    Posted 2 years ago #

    It works now! Thank you!

  21. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the confirmations it is now working, I'll bring out an update in the next few days, if all remains well. Thank you all very much for your assistance and donations too.

  22. laneburris
    Member
    Posted 2 years ago #

    This also appears to work for my MU site as well. I do have a questions ...

    Is it possible to add an option when updating a POST to send an email? (Similar to the one you have to prevent sending an email on a POST.)

    In other words ... I want to have an option to resend an email if I update a POST.

    Thanks for the great plug-in!

  23. mattyrob
    Member
    Plugin Author

    Posted 2 years ago #

    @laneburris,

    While you edit the post revert it's status to draft and then when you are done editing hit Publish - you essentially re-Publish instead of Updating and that will create a new notification.

  24. ghostrose333
    Member
    Posted 2 years ago #

    Thanks for the quick fix MattyRob! :)

  25. typebee
    Member
    Posted 1 year ago #

    The 8.1 version (the zip file is actually 8.31) didn't solve the problem for me. What did was changing the URL to the subscription page. Before I upgraded to WP 3.3.2, the URL was /wp-admin/users.php?page=s2_users.

    The new link it is wp-admin/admin.php?page=s2

    Hope that helps others.

  26. JoPo
    Member
    Posted 1 year ago #

    Does WordPress8.2 have the edited code in it that prevents the "you do not have sufficient permissions to access this page"? My pages sit behind SSO authentication and I am not sure if that is causing issues. But by the looks of it, others have seen this before. At any rate, what can I do to get rid of this dreaded page and make Subscribe2 work for me? I am a superAdmin and cant even subscribe to my own page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags