WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
What is the correct Management URL? (14 posts)

  1. Daedalon
    Member
    Posted 2 years ago #

    The installation instructions to 2.0.2 say
    Customize the Permalink value under Settings > Subscribe to Comments > Management Page > Management URL. It must reflect your permalinks' structure. The default is /comment-subscriptions and its help text is The permalink for your management page (something like /manage-subscriptions or /?page_id=345). This page does not actually exist in the system, but its link must follow your permalink structure.

    This, doesn't tell what should the URL be. The default one and the suggested /manage-subscriptions don't work: clicking the link next to the comment box of a post as an admin gives a 404 error. Clicking the You can also subscribe without commenting. The link in the same place as a non-logged-in-user doesn't work either.

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

  2. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    What's the url?

  3. Daedalon
    Member
    Posted 2 years ago #

    Thanks for the quick reply, camu. I have disabled the plugin and am now trying out Subscribe2. To try Subscribe To Comments Reloaded again I would welcome the exact steps of what needs to be done for setting a Management URL that doesn't return a 404 error. If anyone can post this information, it'd be helpful.

  4. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    But Subscribe2 does a completely different thing :( I'm confused, now! Anyway, if you provide a link to your site, I'll be able to provide the right format for you.

  5. Daedalon
    Member
    Posted 2 years ago #

    You're right. I must have misread somehow that it would also allow to subscribe to individual posts' comments.

    The notification of new comments would be immediately useful on SexandSociety.net and after it's working there, I'd use it also on RusCult.com. Thanks!

  6. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    I see, you have a trailing slash in your pages' URLs. Try this:

    /manage-subscriptions/

    and see if it works :)

    Camu

  7. Daedalon
    Member
    Posted 2 years ago #

    Thanks, tried that. Didn't work at first, but then did a bit more debugging to be sure it's a 404 error. Turns out that it wasn't. The plugin 404 Redirected was causing the problem.

    After disabling it, the link works both with and without the trailing slash in the settings. When it's without, the slash gets automatically appended after clicking. I re-activated 404 Redirected and set its automatic redirection off (should have done that already as I use Smart 404 for that in any case) and now all seem to be working.

    Two ideas. First: The plugin could inform users of the need to turn 404 Redirected's automatic redirection off (until they get this one fixed). Either STCR could check if the 404R is active and then display a warning on the Management Page, or just mention it in the installation instructions.

    Second, about the trailing slashes etc: Wouldn't it be possible for the plugin to query for the permalink structure that the blog uses to tell users automatically how to format the Manage URL field correctly? Something like get_permalink() or permalink_anchor() could be used for that.

    This way instead of saying "its link must follow your permalink structure" we could suggest the user right away what would work and why.

  8. Daedalon
    Member
    Posted 2 years ago #

    Interesting about 404 Redirected is that it redirects the management page of Subscribe To Comments Reloaded to the following address: [SITE]/[SITE]/?page_id=9999999/. Not only is the site twice, for some reason ?page_id=9999999/ gets added in the end.

    The URL for subscription management page is [SITE]/manage-subscriptions/?srp=[ID] where [ID] is the page/post id in question.

    I remembered there are some redirects the site benefits from which Smart 404 doesn't handle but 404 Redirected does, so I hope the authors of 404R and STCR could find why such a crazy redirection occurs when there is no 404 error and how could it be solved?

    Smart 404 causes redirection loop with ?p= parameter might be related. Could it be a bug in is_404()?

  9. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    You may want to create a "real" management page to make 404R happy. Please take a look at the FAQs to see how to do that. This has been added just for cases like yours, where other plugins are not able to properly handle virtual pages :)

    Cheers
    Camu

  10. Daedalon
    Member
    Posted 2 years ago #

    Correction, the problem was resolved when I turned off the following option in the settings of 404 Redirected: "Force current permalinks:
    Creates auto redirects for any url resolving to a post/page that doesn't match the current permalinks". Otherwise the automatic redirects are now active and Subscribe To Comments Reloaded functions as expected.

    So the thing to do is to have STCR find out what's the correct permalink setting for the blog and tell it to the admin to ensure proper links. Maybe after that even the above setting can be activated.

  11. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    So the thing to do is to have STCR find out what's the correct permalink setting for the blog and tell it to the admin to ensure proper links. Maybe after that even the above setting can be activated.

    Good point, but it looks like it's not that easy :) I will be playing with WP_Rewrite to see what can be done.

    Camu

  12. Daedalon
    Member
    Posted 2 years ago #

    Thanks a lot for your help with Subscribe To Comments Reloaded, camu. Appreciated!

  13. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    A vote for my plugin would be a nice way to say thank you!

    Camu

  14. Daedalon
    Member
    Posted 2 years ago #

    I'm always voting to keep the community informed :) Came here back to specifically mention that the plugin works on 3.3 and you might want to update this on the WP plugin page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic