WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
[resolved] Plugin subscribe to comments reloaded causes 404 errors (10 posts)

  1. Marcuss
    Member
    Posted 2 years ago #

    Hello!

    I used the Plugin Subscribe to Comments reloaded and the google Webmastertools shows me a lot of 404 Errors like this:

    http://domain.tld/c​omm​ent​-su​bsc​rip​tio​ns?​srp​=13​54&​sra​=s

    How can I prevent these errors?

    Thanks for your Help

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

  2. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    If it takes you to a 404 page, it means the plugin hasn't been properly configured. Please refer to the installation instructions. Or provide an actual link to your site so that I can help you!

    Camu

  3. Marcuss
    Member
    Posted 2 years ago #

    Hello!

    Thx for your answer!

    The Link to my Site is http://themenfreund.de and the page named 'Kommentare abonnieren'. So the Permalink is http://themenfreund.de/kommentare-abonnieren/

    My Permalink-Structure is /%postname%/ .

    And of from there it I registered under Settings > Subscribe to Comments > Management Page > Management URL /kommentare-abonnieren.

    I think, that would have to be actually correct

  4. ZehrGut
    Member
    Posted 2 years ago #

    Hello!
    The same with me.
    Will wait for camu reply

    I have searched his forum hundreds of time. It seems very common problem.

    Marcuss, but it seems everything is fine with your blog now?

  5. Marcuss
    Member
    Posted 2 years ago #

    Yes, in the Frontend everything is fine!

    But google WMT are added each day new 404er error, which harms reliably the standing of the Domain, if 1000 errors are counted sometime

  6. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    @Marcuss,

    you have a missing trailing forward slash in your URL, it should be:

    /kommentare-abonnieren/

    since your permalink structure includes that. You are just redirected to the right page (look at the url BEFORE clicking on it and AFTER), you'll see the difference. Once you fix your configuration, all those 404's will go away :)

    A vote for my plugin would be a nice way to say thank you!

    Camu

  7. ZehrGut
    Member
    Posted 2 years ago #

    @camu
    Thanks! Just tested on localhost And completely agree about trailing slash.
    Both "Permalink Settings" and "Subscribe To Comments" should have or haven't trailing forward slash.

    But in my case "Permalink Settings" is /%postname%-deals

    And I can't get it working in any case :(

    It's OK only in case of ?page_id=999999999.

  8. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    @ZehrGut,

    the management page URL has to match what you have in your permalink settings, it's not always a matter of trailing slash, like in your case. You may want to set it up to

    /comment-management-deals

    Camu

  9. ZehrGut
    Member
    Posted 2 years ago #

    camu
    Thanks a lot! Now it's working like a charm!
    How I can't guess to make it this way!?!?!

    By the way (it's off-topic here) I'd like to subscribe to comments without commenting. But I don't like first clicking on link. I want to have subscribe form right on post page.

    Currently I've pasted the code below to my single.php:

    <form action="/subscriptions-coupon-code?srp=<?php the_ID(); ?>&sra=s" method="post" onsubmit="if(this.sre.value=='' || this.sre.indexOf('@')==0) return false">
    	<fieldset style="border:0">
    	<p><label for="sre">Email</label> <input type="text" class="subscribe-form-field" name="sre" value="" size="22" onfocus="if(this.value==this.defaultValue)this.value=''" onblur="if(this.value=='')this.value=this.defaultValue">
    	<input name="submit" type="submit" class="subscribe-form-button" value="Send"></p>
    	</fieldset>
    </form>

    Of course this is "fast and dirty" solution. But how else?
    Thanks in advance!

  10. camu
    Member
    Plugin Contributor

    Posted 2 years ago #

    That's exactly how it can be done.

    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic