WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
[resolved] hi, how to subscribe only to replies? (34 posts)

  1. Alexandru Vornicescu
    Member
    Posted 3 years ago #

    is it possible to make the plugin to work in this way?:
    if a new comment is posted to the blog, the subscriber will not receive updates via e-mail if this comment is not a reply to his comment.

  2. camu
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Alex,

    in order to add this feature, a new checkbox (or a dropdown menu) would have to be shown to the user, in order to let him/her decide what kind of subscription s/he wants to activate. Also, what if the user posts 2 comments? Should he receive notifications for replies to both? Only the first one? I think this would confuse a lot of people.

    This doesn't mean that in the future I may change my mind and implement such a feature, but it's not something that will happen soon.

    Camu

  3. Alexandru Vornicescu
    Member
    Posted 2 years ago #

    thanks for the reply!

    Yes, a dropdown menu would be great and the user will receive e-mails notification for the replies to his comments only.

  4. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    as I said, this is not something that will be added in the near future. I still think it would confuse people and administrators.

    Camu

  5. wliebman
    Member
    Posted 2 years ago #

    I've been looking for a plugin that would offer exactly this option--subscription to replies only, not to all comments. So far, Intense Debate is the only one I've found, and it's as you say, a dropdown that gives the commenter three subscribing options: Subscribe to a) none b) replies c) all comments. There's nothing confusing about it. (But I find Intense Debate problematic in other areas.)

    As a commenter, sometimes I'm only interested in replies to my own comments. I don't want my email box inundated with stuff I don't care to see.

    On my own blog, I always respond to comments, and I tell my readers this when I encourage them to comment. A subscription to replies option would enable them to see my response to them without their having to come back to the website, find the post again, and scroll down. I'm always interested in making things easier for readers, and for encouraging them to comment.

    Perhaps a second comment might cause some confusion, but 2nd comments are the exception, not the rule, and I think the trade off would be well worth it.

    I hope you re-consider implementing this option. I'd gladly pay for it.

  6. Alexandru Vornicescu
    Member
    Posted 2 years ago #

    wliebman - I will try Intense Debate, but yeah! - what you said in your post is like reading my mind, I have exactly the same opinion.

  7. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Okay guys, I guess you win :) I will add this to my todo list. Adding it as an option will make everybody happy: those who think it's confusing (like me) will be able to disable this feature.

    Camu

  8. wliebman
    Member
    Posted 2 years ago #

    Everybody wins :-) The option to disable is brilliant. When this is implemented, you will have made a popular and excellent plugin more popular and more excellent, even Indispensable.

    BTW, what I find problematic in Intense Debate is that it's intrusive. The commenter has to jump through hoops, or at least wade through a puddle, to make a comment. The elegance of Comments Reloaded is its transparency--it does what it does without calling attention to itself. Much control on the back end for the administrator, a sense of effortlessness on the front end for the commenter.

    Can't wait.

    And thanks.

  9. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for your donation, wliebman! I'm almost done updating my other plugin, WP SlimStat. I will resume working on StCR as soon as possible. The new version will have a lot of new interesting features, thanks to your feedback! I really appreciate it.

    Best,
    Camu

  10. Alexandru Vornicescu
    Member
    Posted 2 years ago #

    any news ?

  11. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Not yet :( Let's see how it goes this summer.

    Camu

  12. John
    Member
    Posted 2 years ago #

    I would like to express my interest in this as well.

  13. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Cool.

  14. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, guys, I've started working on this feature. I was updating the code, but then a question popped up. When you say 'subscribe to replies', to WHAT replies should the user be subscribed? To a reply to ANY of the comments made by me or to a SPECIFIC comment? I would guess the former, because the latter could easily become confusing for your visitors.

    Any feedback on this? I am currently implementing the first option...

    Camu

  15. wliebman
    Member
    Posted 2 years ago #

    Yes, I think the former--replies to any comment the subscriber makes. It's simpler, and more inclusive. If as a reader I made a second or third comment, I'd be interested in replies to those as well.

    (I think you might want to make it clear to the commenter that this is the case, to save him signing up for replies again if he comments again.)

    Really looking forward to this and very grateful you're working on it.

  16. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Cool, that's exactly what I had in mind. I've actually just completed the 'core' of this new feature. At the same time, though, I'm also implementing a new engine that relies on WP core tables (without modifying them, like the old Subscribe to Comments by Mark Jaquith used to do), to eliminate the need of a separate table.

    This will make my plugin fully compatible with WPMU, for those who have asked about it. But it will take a few weeks to update all the pieces to use this new approach.

    Stay tuned.

    Camu

  17. Raam Dev
    Member
    Plugin Author

    Posted 2 years ago #

    I see that the latest version of this plugin (v2.0.2) has the new "Advanced subscription" option where I can offer my readers the option to subscribe to all or replies only, however it doesn't work.

    I tried posting two separate comments to a post, choosing subscribe to "All" for one and then "Replies Only" for the other, however the commenter who chose "Replies Only" received notifications for all comments, not just the comment he posted.

    Any idea what's going on?

  18. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Raam,

    can you post or send me the URL of your site so that I can run some tests? It seems to be working fine in my test environment...

    Camu

  19. Raam Dev
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Camu,

    My site is at http://raamdev.com and I'm running the latest version of the plugin and the latest version of WordPress. Let me know if there's anything else you need.

    Cheers,
    Raam

  20. camu
    Member
    Plugin Author

    Posted 2 years ago #

    I just posted a test comment and I set the corresponding subscription to 'replies only'. Please post 2 comments to that article, one replying to mine, the other outside that thread.

  21. Raam Dev
    Member
    Plugin Author

    Posted 2 years ago #

    All done.

  22. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Sent two new comments per your request. Let's see what happens when you approve them :) I suspect it has something to do with the fact that you have WordPress moderation system active. Or a conflict with another plugin.

    Even if our last test was successful and the plugin behaved the way it was supposed to.

    Camu

  23. wliebman
    Member
    Posted 2 years ago #

    Camu,

    I've continued following this thread with interest. I've implemented the advanced comment option on my website, of course, being one of the instigators. I tested it yesterday, having a couple of subscribers make comments and report back to me. Both checked the "replies only" option. For one, it worked like a charm. But the other keeps getting emails of my replies to everyone else's comments, not just replies to his own comment. He doesn't get emails when other subscribers comment, just my replies to them.

    I'm running the current views of WordPress and the plugin. I do use the WordPress moderation system in that anyone commenting for the first time must have their comment approved. But the two testers above are veteran commenters.

    Hope this helps.

  24. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi there,

    what is the status of those two subscriptions? R or RC? From the information I'm gathering, it looks like there's a problem with pending subscriptions (status = RC). Let's see if we can solve the mystery together.

    Camu

  25. Raam Dev
    Member
    Plugin Author

    Posted 2 years ago #

    FYI, I also have the same configuration as wliebman: Anyone who comments for the first time must have their comment approved by a moderator, but once a comment has been approved, future comments using the same email address do not require moderation.

    I also don't have the "double check" enabled, so people can subscribe to comments without responding to a confirmation email, which makes me wonder: How could a subscription be marked RC unless someone went into the management page and suspended their subscription? That should be the only way to achieve RC if "double check" is disabled, correct?

  26. camu
    Member
    Plugin Author

    Posted 2 years ago #

    I also don't have the "double check" enabled, so people can subscribe to comments without responding to a confirmation email, which makes me wonder: How could a subscription be marked RC unless someone went into the management page and suspended their subscription?

    Well, that's not the only reason why a subscription would be pending. If the corresponding comment hasn't been approved, the subscription will be pending too ;)

    Anyway, it looks like the problem is only with comments SENT by the author of the post/administrator of the blog, not by other readers. I received all the notifications for your comments to the post "Income Ethics: Planetary Social Responsibility", even if they weren't replies to my comments, but I didn't receive any when other people where leaving a comment that wasn't a reply to mine.

    Camu

  27. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, just so other users know, I found why this was happening: there was a bug in the SQL retrieving the subscriptions from the database. The fix has already been posted to the repository (the version hasn't changed). You may want to manually download version 2.0.2 and replace all the files on your server via FTP (no subscriptions will be lost!).

    Please let me know if the fix is working!

    Camu

  28. Raam Dev
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the quick fix, Camu!

    I've installed the newer files and confirmed that 'replies only' subscriptions are working properly now.

    I suggest updating the version of the plugin so other users get notified that there's a new version to download and so they're not running a buggy version.

    Cheers,
    Raam

  29. camu
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Raam,

    I suggest updating the version of the plugin so other users get notified that there's a new version to download and so they're not running a buggy version

    Good point, but I'm also working on some new features, and I don't want to annoy people with too many releases :)

    Thank you for your patience and for helping me fix this bug!

    Camu

    PS: don't forget to vote for my plugin!

  30. dikkevandale
    Member
    Posted 2 years ago #

    Great plugin, using it a long time now, but after the update I don't want to use the "replies only" feature.

    So I disabled it, but when users enter their "management" page, they can still change it to "replies only".

    That should be disabled also..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic