WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe To Comments Reloaded
clash with "WordPress SEO by Yoast" (2 posts)

  1. Andrew Biss
    Member
    Posted 3 years ago #

    Hi,

    Great plugin and a recommend update from Subscribe to Comments.

    When testing Subscribe to Comments Reloaded I had a problem with the management page not being displayed; instead WordPress issued a 301-redirect to the blog's home page.

    The cause of the problem is a clash between Subscribe to Comments Reloaded and the WordPress SEO by Yoast plugin, specifically: the Redirect ugly URL's to clean permalinks option.

    The WordPress SEO by Yoast plugin did not recognize the URL that was being dynamically created for the management page and redirected to the blog home page instead.

    When I turn the Redirect ugly URL's to clean permalinks option off the subscription management page appears as expected.

    Looking at the code for Redirect ugly URL's to clean permalinks I saw class-frontend.php checks at line 537 for the wp-subscription-manager URL used by the original Subscribe to Comments plugin from Mark Jaquith:

    // Prevent cleaning out the WP Subscription managers interface for everyone
    foreach (array('wp-subscription-manager') as $get) {
       if ( isset($_GET[$get]) ) {
          $properurl = '';
       }
    }

    This is why the original Subscribe to Comments plugin works OK with WordPress SEO by Yoast when the Redirect ugly URL's to clean permalinks option in enabled, but Subscribe to Comments Reloaded does not.

    I have turned off Redirect ugly URL's to clean permalinks for now.

    The real solution is a patch to WordPress SEO by Yoast to not redirect the dynamically generated subscription management page from Subscribe to Comments Reloaded.

    I hope this explanation helps anyone else who runs into the same problem.

    Andrew.

    http://wordpress.org/extend/plugins/subscribe-to-comments-reloaded/

  2. camu
    Member
    Plugin Author

    Posted 3 years ago #

    Hi there,

    thank you for this wonderful feedback. This was a known problem, but it's good to see that other people are finding ways to solve the issue. Hopefully they'll change the other plugin to make it compatible with StCR.

    Best,
    Camu

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic