WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Subscribe To Comments Reloaded] bug: connects to top domain only (28 posts)

  1. derekbeck
    Member
    Posted 3 years ago #

    I installed this, and was look forward to its functionality, but the variable [manager_link] is ignoring the fact that my blog is not on the top domain.

    I have http://www.derekbeck.com/1775/ as my blog.

    In the Subscribe admin section, it properly prompts this page as the management page: http://www.derekbeck.com/1775/comment-subscriptions

    Yet, the subscribe link that's placed on my comments section, the code for which calls the link address via the variable [manager_link], redirects people to http://www.derekbeck.com/comment-subscriptions

    thus ignoring the fact that my blog, and the manager link, should be down a folder, under 1775.

    Perhaps other variables are broken in the same manner. I've temporarily disabled this, but hope to get it to work.

    Any ideas how to fix? It needs to understand my base for my blog is /1775/ and not /

    Thanks,
    Derek

  2. derekbeck
    Member
    Posted 3 years ago #

    now posted at http://lab.duechiacchiere.it/index.php?topic=132.0

    (the plugin's support page)

  3. camu
    Member
    Posted 3 years ago #

    Hi there,

    are you using version 1.4? Because this was a bug in 1.3, but I thought I had fixed it.

    Best,
    Camu

    PS: my support forum is currently under 'attack' so I had to disable some features and delete a bunch of fake accounts, so please let's use THIS forum here on WordPress for now ;) Thanks!

  4. derekbeck
    Member
    Posted 3 years ago #

    Hi Camu,

    Thanks for the reply. Yes, I have 1.4. I did have 1.3 when I first posted this, but then saw the update to 1.4, and it still doesn't work, but slightly different problem: Now I get the error, when click on "subscribe without commenting", which sends me to

    http://www.derekbeck.com/1775/comment-subscriptions?srp=254&sra=s

    the error is "page not found" (listed in my title), and just opens up my blog roll page. it does not open any comments page tool.

    before, it was looking for the page at the top domain level, so it appears the base domain /1775/ is now working indeed, but it still doesn't work for me.

    fyi, I've been keeping the plugin disabled except during testing, but am leaving it on for right now, until I post my next update this weekend anyhow, for you to look at if you like.

    Thanks for your support! Sorry to be the bearer of bad bug news...

    Derek

  5. camu
    Member
    Posted 3 years ago #

    Hey Derek,

    don't worry about the 'bad news', I'm more than happy to support my plugin and its users. As far as I can see, though, in this case it's not a problem with my plugin, but with the way you configured it. I see your blog is not under /1775/ but under /1775/info/ . If I test this URL

    http://www.derekbeck.com/1775/info/comment-subscriptions/?srp=1&sra=s

    it works fine. So please update the corresponding option in your control panel to match your permalink settings and let me know if it works :)

    Thank you,
    Camu

  6. camu
    Member
    Posted 3 years ago #

    Also, unfortunately your theme isn't very well designed, and that's the reason why you see a list of the latest comments on that page. Please contact the person who developed it and ask him to fix the 'page' template of your theme accordingly.

    Camu

  7. derekbeck
    Member
    Posted 3 years ago #

    Hi Camu: thanks for again for the reply.

    Okay, I guess I have 2 issues:

    Re: your first post: the /info/ is part of my permalink structure to post pages, not "page" pages. So I added that /info/ in the location in your plugin's settings tab and that fixed the subscribe link, as you guessed it would.

    But, re your second post: fix the 'page' template: but as I see from above, this is not a page, it is a post. For example: here's a page:

    http://www.derekbeck.com/1775/about/

    and here's a post:

    http://www.derekbeck.com/1775/info/chapter-outline/

    Note I have no info required for pages, only posts.

    So, is there something going perhaps with the plugin still, if it's meant to be showing the comment subscription manager on a "page" versus a post?

    And just so i'm aware: what is the page supposed to look like: no comments from other posts I imagine?

    I was about to submit this reply, when a thought occurred to me to run a test: I just activated the Twenty Ten 1.1 theme, opened my site and subscription page, and I got the same list of comments. For example, on the page http://www.derekbeck.com/1775/info/chapter-outline/ there are no comments, but if I clicked subscribe w/o commenting on that page, I saw all the comments from my other post. Thus, something else is going on here, maybe my setup, maybe the plugin, but definitely not the theme, as Twenty Ten 1.1 theme is about as generic as they get.

    Derek

  8. camu
    Member
    Posted 3 years ago #

    I see, this is something I don't really understand :) TwentyTen 1.3 alpha works fine in my case, both in production [1] and in my test environment. It must be some plugin that you have and I don't, or maybe a different version of WordPress? Can I get access to your WP so that I can take a look at your template and other settings? I promise I won't break anything... You can contact me at http://www.duechiacchiere.it/contatto

    Best
    Camu

    [1] http://www.duechiacchiere.it/notifiche - This is not TwentyTen, but I switched to that for a few minutes earlier this morning.

  9. derekbeck
    Member
    Posted 3 years ago #

    I'll email you. In the meantime, fyi: I turned off every widget, plugin (but yours), and went to the Twenty Ten 1.1 theme again, and still the problem persisted. I think it might have something to do with my permalink structure. I'm using WP 3.0.2.

  10. camu
    Member
    Posted 3 years ago #

    Hey Derek,

    I answered your question via email. Could you please mark this topic as solved?

    Thanks,
    Camu

  11. derekbeck
    Member
    Posted 3 years ago #

    Hi Camu,

    I've been toying with the results.

    First, to any future reader of this post, camu replied to me by email:

    I've been trying to debug your template, and finally I found the culprit. If you go Appearance >Atahualpa Theme Options > Comments (left column), you'll see there's an option which says

    Allow comments on "Page" pages, too?

    This option is currently set to 'Yes', and if you change it to 'No', comments will disappear from the management page. As I thought, it was a problem with your template, not the plugin. I have left this option set to 'No'. Please let me know if you have questions...

    I have to say, I can't understand this, but: after reading your response, I was perplexed: why did I see the problem on other themes, after all? However, I deliberatly wanted comments on pages too, so I turned it back on, and strangely: now if you go to the subscribe page, even with the comments on pages turned back on, it now is fixed (though it does say "comments closed" at the bottom of the subscribe pages). In short, I'm perplexed that turning the switch you turned off back on does not reintroduce the problem. I'm equally perplexed that the problem presented itself on other themes but no longer does. Very strange.

    I would say, if your plugin doesn't allow page comments ordinarily (although it is now seemingly allowing this on my site), that it should.

    I should note, I added this to my code to test what wordpress thought of your manage subscription pages:

    <?php
    if ( is_single() ) { ?>
    	<H1>SINGLE</H1>
    <?php }
    if ( is_page() ) { ?>
    	<H1>PAGE</H1>
    <?php } ?>

    The result was that WP thought it was a page, not a post. Strangely, it follows my permalink structure for posts: blog.com/info/comment-subscriptions/?query

    whereas my pages have distinct names usually: blog.com/about/ for example.

    Since the page does not really exist that this info appears on, it seems one cannot isolate it to choose to discard comments from that page. I wish the plugin would point to some blank real page, which would be very helpful.

    On a side note: a few tweaks I'd like to see:

    1) wish either the email textbox had no value or otherwise when you clicked it the "email" disappeared using javascript;

    2) wish the name of the article on the subscription management page was a link back to the article, and that a link back existed after someone subscribes without commenting;

    3) there's no obvious way for a user to get into the subscription page after they've confirmed their email address, except when a new update is emailed to them. This doesn't bother me much though, but if I turn off the double-opt-in email option, a user has no way of getting this info until they get an update. Perhaps then, with double opt-in turned off, a user should still get an update when the subscribe, telling them they've successfully subscribed (or at least make it an option).

  12. derekbeck
    Member
    Posted 3 years ago #

    On my sidenotes: I see how I can could, in theory, customize the #2 and #3 to get those results. For example, for #2, I placed in the "Subscribe without commenting" custom notification:

    You can follow the discussion on [post_title] without having to leave a comment. Just enter your email address in the form here below and you're all set.

    However, that customization box says below it: Allowed tag: [post_title] (and does not allow post_permalink apparently). I tried it anyhow, and it doesn't work. Instead, it links to the following literal address:

    http://www.derekbeck.com/1775/info/comment-subscriptions/post_permalink

    (in my case).

    Derek

    Definitely by biggest desire would be to have your plugin set to a real page, that I could then highly customize as desired (such as restricting the comments notice).

  13. camu
    Member
    Posted 3 years ago #

    To tell you the truth, version 1.0 of my plugin used a REAL page, but then I got a few requests from other users BEGGING me to remove that page :) So I did what I was asked for, and the page disappeared. It seems that having a 'real' page is a pain in the neck for most users because then it appears in their navigation and the like. I agree on that, and I'm still convinced that a 'fake' page (like the other plugin does) is the best option for most people.

    Having said that, you can still have a real page if you want, there's a workaround that involves creating a template in your theme. If you want to know more about how to do it, just send me a message and I'll step you through it.

    As for your other requests, I'll see what I can do :)

    Camu

  14. derekbeck
    Member
    Posted 3 years ago #

    Quite interesting on the other reactions by people, as it is quite easy to disable a page from appearing in say the menus, unless I'm missing the point of the problem... I'll send you the email.

    Hopefully my list of tweaks are not daunting, and that you take it as a challenge to perfect your plugin, which is clearly the best one available. (I've tested the others, they all have some flaw, in my opinion.)

    One other tweak that I cannot figure out: the checkbox label for an unsubscribed user at least: has an extra space " " before the label itself. This can be seen by digging into the code. It throughs off my alingment of the label in relation to other labels that appear when one logins with twitter or facebook. This space is not in the text box in the setup options, so it is being inserted somewhere along the way in the plugin. Any ideas? (PS: you should consider putting the whole label in a <label> tag with an ID so it can be CSS styled. Right now, it's just inside a <p>.)

    derek

    PS: for any reading this: don't lose sight of the big picture here: this is a great plugin, and your best option for email subscriptions to comments.

  15. derekbeck
    Member
    Posted 3 years ago #

    And i see this forum coverted what I was trying to say above, in comment before last, which should read:

    You can follow the discussion on <a href="[post_permalink]">[post_title]</a> without having to leave a comment. Just enter your email address in the form here below and you're all set.

  16. camu
    Member
    Posted 3 years ago #

    (PS: you should consider putting the whole label in a <label> tag with an ID so it can be CSS styled. Right now, it's just inside a <p>.

    You can customize this the way you want. Not putting the label is intentional, because then each user can do whatever s/he wants. Just go to the Options panel and add the html/css code you need :)

  17. camu
    Member
    Posted 3 years ago #

    the checkbox label for an unsubscribed user at least: has an extra space " " before the label itself.

    Again, you have the freedom to remove that extra space by customizing the corresponding option under Settings :) As you may understand, that space is actually required by accessibility and by most other themes. I hope you don't think your needs are EVERYBODY'S needs :)

  18. derekbeck
    Member
    Posted 3 years ago #

    Ah, I see it: my apologies:

    for those not following along: in the settings, options tab: Custom HTML: make it:

    <label>[checkbox_field][checkbox_label]</label>
    (there's a space in the default between the two variables above)

    Thanks camu!

  19. camu
    Member
    Posted 3 years ago #

    However, that customization box says below it: Allowed tag: [post_title] (and does not allow post_permalink apparently). I tried it anyhow, and it doesn't work.

    This and a few other options have been added to 1.4.1, which I hope to release in a couple of weeks.

    Camu

  20. derekbeck
    Member
    Posted 3 years ago #

    Awesome... I'll be sure to keep my eye out for the upgrade.

    re:

    1) wish either the email textbox had no value or otherwise when you clicked it the "email" disappeared using javascript;

    I did find where I could change it by digging into the code. I didn't see how to readily make it javascript to disappear the initial value upon clicking it, like the subscribe button is on my right sidebar on my site, so I just made the value nothing. But I saw that the value also is linked to a cookie call, so hopefully I didn't break anything by making that change.

    Derek

  21. camu
    Member
    Posted 3 years ago #

    Yes, that will be added too ;)

    Camu

  22. derekbeck
    Member
    Posted 3 years ago #

    Camu, you're awesome!

    For any reading this: if you have doubts on whether to use this plugin: don't. You can see the support of the plugin by camu is excellent, and it's clear he really cares about making the best plugin possible. If you want to have subscribe to comments on your website, this is the plugin to use. Don't bother testing out the others (as I have), you're just wasting your time.

  23. camu
    Member
    Posted 3 years ago #

    Well, thank you for your nice words. If you want to contribute to make it even better, you may want to correct any grammar or other errors in the various sentences around, since you're an English speaker and a director :) I've tried my best, but I'm a still an ESL guy...

    Camu

  24. derekbeck
    Member
    Posted 3 years ago #

    I'll let you know if I see any grammar stuff, but haven't noticed any to be honest, and your English is quite good.

  25. camu
    Member
    Posted 3 years ago #

    Thanks, dude :D (this is my favorite English word)

    Camu

  26. camu
    Member
    Posted 3 years ago #

    Version 1.5 has been released just a few minutes ago. Please let me know if you have any questions about the new features you had asked about.

    Thanks,
    Camu

  27. derekbeck
    Member
    Posted 3 years ago #

    I saw your update, and looks good. I've made the post-link updates and they seem to work perfectly.

    The only tweak remaining that I'd really like to see is this one:

    1) wish either the email textbox had no value or otherwise when you clicked it the "email" disappeared using javascript;

    Happy Holidays!
    Derek

    PS: Thanks for the update!

  28. camu
    Member
    Posted 3 years ago #

    Oh, I thought I had implemented that :)

    Happy Holidays to you too!

    Camu

Topic Closed

This topic has been closed to new replies.

About this Topic