WordPress.org

Ready to get started?Download WordPress

Forums

Plugin: Subscribe me (52 posts)

  1. Denis de Bernardy
    Member
    Posted 9 years ago #

    http://www.semiologic.com/projects/subscribe-me/

    The subscribe me plugin for WordPress adds buttons at the end of your sidebar so your visitors can subscribe to your blog via services such as Bloglines and MyYahoo!.

    This is the official support thread.

  2. jfriesen
    Member
    Posted 9 years ago #

    I like this plugin alot, but it generates non-compliant code because of ampersands in the URIs. I replaced those with & but when viewed in the browser, the My MSN link reverts back to the ampersand in the URI; the other links retain my & substitution.

    Why is just the My MSN link problematic?

    <a href="http://my.msn.com/addtomymsn.armx?id=rss&amp;ut=<?php echo $feed_url; ?>&amp;ru=<?php echo $blog_url; ?>" class="subscribe"><img src="<?php echo $img_dir . "addmymsn.gif"; ?>" alt="MyMSN" /></a>

    thanks!
    JF ;)

  3. Denis de Bernardy
    Member
    Posted 9 years ago #

    as far as I know, ampersands are valid in urls... and quite frankly: who cares if your page validates or not? :)

  4. del410
    Member
    Posted 9 years ago #

    Thanks, I was looking for one of these! Hope it works...

  5. Denis de Bernardy
    Member
    Posted 9 years ago #

    I've uploaded a minor upgrade. It now automatically removes the borders from the image links, and adds a text caption to the XML button.

  6. sagetips
    Member
    Posted 8 years ago #

    Hi -

    I cannot seem to get button images to show. I uploaded all contents (including image files) to plug-in directory. Was this incorrect?

    The url is http://www.sagetips.com/heloc-blog/index.php

    Thanks for any help. I'm new to WP so sorry if the question is overly basic

  7. sagetips
    Member
    Posted 8 years ago #

    Please disregard my earlier post. I've found problem.

  8. rwj850t
    Member
    Posted 8 years ago #

    My site is hosted with Dreamhost. When I use this plugin with the Semiologic CMS, I see this error message twice on my blog:

    This plugin requires php's built-in XSLT parser. Contact your host about the problem, or download and manually install the obsolete plugin.

    I'm uncertain which file or files I need to install when I follow the link. Conversely, I'm not sure why I need my host to do so I can use the current version.

    Thanks!

  9. Jesters8
    Member
    Posted 8 years ago #

    Are there any plans to add Google support to the plug-in?

  10. Denis de Bernardy
    Member
    Posted 8 years ago #

    @rwj850t: you sure you don't mean one of the recent posts, updates or comments plugins? if so, try downloading the latest, it includes some code to will normally make it php5 compatible.

  11. Denis de Bernardy
    Member
    Posted 8 years ago #

    @jester: to which plugin?

  12. rwj850t
    Member
    Posted 8 years ago #

    Nope, I mean the subscribe me plug-in. See:
    http://pfdebate.com/index.php

    Thanks!
    Bob Jordan

  13. Denis de Bernardy
    Member
    Posted 8 years ago #

    aye, those two are the recent plugins. try disabling fuzzy recent posts, fuzzy recent updates and fuzzy recent comments.

  14. Jesters8
    Member
    Posted 8 years ago #

    sorry, to subsribe me

  15. Denis de Bernardy
    Member
    Posted 8 years ago #

    er, can you be more specific? i wasn't aware google had anything like bloglines.

  16. Jesters8
    Member
    Posted 8 years ago #

    yup, it's similar to my yahoo i think. http://www.google.com/ig is a personalized homepage that can display headlines from any rss feed.

  17. Denis de Bernardy
    Member
    Posted 8 years ago #

    sure i guess... send me the relevant code by email (denis at semiologic dot com).

  18. isthmian
    Member
    Posted 8 years ago #

    I can't get my button images to show up. I placed my images in the folder called sem-subscribe-me. I also tried them in the wp-images folder without luck. What am I missing here?

  19. IZMO
    Member
    Posted 8 years ago #

    I'm having the same problem. The links appear when you roll over the area that I placed the plug-in but no images.

  20. Denis de Bernardy
    Member
    Posted 8 years ago #

    well, my guess is you put the images in the wrong directory. and without a link to your site, there's absolutely no way to tell.

  21. IZMO
    Member
    Posted 8 years ago #

    I put them all in the plugin directory, activated the plug in and put the line of code (<?php sem_subscribe_me(); ?>) into the Sidebar.php.

    The blog is on my test site at wp.adammersky.com/yossi2

  22. Denis de Bernardy
    Member
    Posted 8 years ago #

    looks fine... what's wrong on it?

  23. IZMO
    Member
    Posted 8 years ago #

    I can't see the images. I've looked at it on Firefox, IE and Opera. I also would love to get rid of the second 'Subscribe' header but have no idea how.

  24. kenbonner
    Member
    Posted 8 years ago #

    I'm having the same dilemma as IZMO in regards to not seeing the .gifs in the sidebar (see http://kennethbonner.com/). I've placed the images in various folders on the site (both \img folder and the wordpress repository) and changed the path in the plugin php. I've included the same line in my sidebar.php as Mr. IZMO, too.
    Any suggestions?

  25. Denis de Bernardy
    Member
    Posted 8 years ago #

    the default directory is:

    wp-content/plugins/sem-subscribe-me/

    and it works.

  26. kenbonner
    Member
    Posted 8 years ago #

    Denis, you're correct, the plugin is, technically working. ...However, I'm not able to get the images to load. I think it has to do with the $img_dir parameter being set relative to a 'home' location. Can you tell me where and what wordpress uses for this (relative to the dashboard?).
    I am using a default installation setup for the 'subscribe-me' plugin.

  27. Nicki Faulk
    Member
    Posted 8 years ago #

    Regarding jfriesen's post, I am having this problem too, albeit a minor problem. And in the response: "... and quite frankly: who cares if your page validates or not?"

    Um, I do. :P

    Oh well, anal-retentive perfectionists like me will just have to get over that huh? ;)

    Anyways, my main reason for coming here: I modified my Subscribe me plug to include LiveJournal. LJ now offers syndication, so all I had to do is just add the link to the bottom of the item list in the plug. :)

    I didn't know about the Google thing, checking that out now. :D

  28. kenbonner
    Member
    Posted 8 years ago #

    Well, I managed to figure out why the images weren't loading. I opened IE (instead of FF) and saw the image placeholders. I right clicked and went to PROPERTIES and saw that instead of the correct plugin subfolder (subscribe me folder), it was pointing to a non existent file on the ROOT of my site. I temporarily moved the gifs to the root, but does anyone know of a solution to this problem?
    Thanks,
    Ken

  29. IZMO
    Member
    Posted 8 years ago #

    This issue keeps getting weirder by the minute. Now without any edits on my part different images show up everytime I refresh the page. Once the MSN gif will show. The next time only the newsgator gif will show. And the plain XML gif won't provide the correct feed information.

    When I view the page on my wife's Mac it looks fine but on my PC it never looks right. Thoughts?

  30. Denis de Bernardy
    Member
    Posted 8 years ago #

    izmo, if I may suggest, uninstall the script, download it again, and install it properly. the plugin works out of the box.

Topic Closed

This topic has been closed to new replies.

About this Topic