WordPress.org

Ready to get started?Download WordPress

Forums

SublimeVideo (deprecated)
[Plugin: SublimeVideo] Firefox doesn't like source element wrapped in p element (3 posts)

  1. Rémy
    Member
    Posted 2 years ago #

    Hi,

    I'm Rémy from the SublimeVideo team.

    I've noticed a bug that is very annoying and blocking. Indeed it seems to prevent Firefox from playing a video.

    The issue comes from the fact that you're generating the <video> tag and <source>s tags in a big multiline string with tabs in it. Unfortunately, it seems that Firefox transforms the multiline with tabs in <p> elements, thus putting some <sources> tags in <p> elements. The problem is, while doing this, this browser doesn't succeed to play the <source> when in <p>. I've setup a simple page to show you what I mean (with and without SublimeVideo): http://test.sublimevideo.net/source_in_p

    Could you please generate a <video> and <source>s elements without those unnecessary and problematic newlines/tabs?

    Thanks in advance, hopefully we should release our official plugin sometime soon during the summer, but it would be great if you could fix this in your plugin in the meantime.

    http://wordpress.org/extend/plugins/sublimevideo/

  2. Jon Breitenbucher
    Member
    Plugin Author

    Posted 2 years ago #

    I'll try and fix it in the next week or so.

  3. Jon Breitenbucher
    Member
    Plugin Author

    Posted 2 years ago #

    It seems none of my testing sites are loading the player (They seem to be setup correctly in the MySublimeVideo area.), so I can't really test the fix. I can send it to you for testing if you'd like.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic