WordPress.org

Ready to get started?Download WordPress

Forums

SubHeading
[resolved] is_main_query fatal error on wp prior to 3.3 (5 posts)

  1. DrLightman
    Member
    Posted 1 year ago #

    Hi, I know that one should mantein his WP always up to date, but in my case I have to wait.

    I updated subheading to 1.6.6 and it was broken in my WP 3.2.1 because is_main_query doesn't exist in that WP version.

    Could that function be substituted with anything else function/s that does the same thing maybe?

    http://wordpress.org/extend/plugins/subheading/

  2. DrLightman
    Member
    Posted 1 year ago #

    Apparently, this could be of help:

    https://gist.github.com/1297669#gistcomment-58619

  3. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I will look into this in order to add some backwards compatibility in order to get it working on 3.2.1.

    Thanks for highlighting the problem.

  4. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Hello again,

    I have made some modifications and committed an update to the plugin, tagged as version 1.6.7.

    Some brief testing was carried out with WP 3.2.1 and it seemed to work for me, give it a try and hopefully resolves your issue.

  5. DrLightman
    Member
    Posted 1 year ago #

    Thank you I'll give a try as soon as I can

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic