WordPress.org

Ready to get started?Download WordPress

Forums

Styles
[resolved] Question about Fonts (8 posts)

  1. stayc215
    Member
    Posted 2 years ago #

    In Chrome the browser blocks content saying it's insecure then it runs down all these google api's. So I clicked on one of the links and it took me here: http://fonts.googleapis.com/css?family=Supermercado+One. Then from there I went here: https://developers.google.com/webfonts/docs/getting_started
    Would this have something to do with styles? I love this plugin and I just rated it a 5 and said it works with current version.

    http://wordpress.org/extend/plugins/styles/

  2. stayc215
    Member
    Posted 2 years ago #

    Another issue, I had deleted 2 images from Theme footer area and they wont delete themselves so I get a 404 error on that too.

  3. stayc215
    Member
    Posted 2 years ago #

    May have resolved 2nd issue as I changed it to transparent.

  4. Paul Clark
    Member
    Plugin Author

    Posted 2 years ago #

    Hi stayc215,

    Thanks for your support and kind words. The error you're getting from Chrome usually comes up when a page has HTTP content on an HTTPS page. I'm assuming your site is being accessed over HTTPS? In that case, the font addresses need to be changed to match. Please try the two versions of the plugin below and let me know if one of them resolves your problem. If so, I'll update the plugin for everyone.

    Option 1 - SSL Agnostic, should work for sites on HTTPS or HTTP.

    Option 2 - Force SSL, should work on HTTPS only.

    Option 1 is the appropriate fix for everyone. If it doesn't work, option 2 should work in your particular case by forcing the use of HTTPS.

    Each version will need to be downloaded, unzipped, then installed in place of your existing Styles plugin using FTP. Please let me know if that is not possible.

  5. stayc215
    Member
    Posted 2 years ago #

    Thanks for your prompt response. I am very new at this so I'm super nervous. I am not comfortable with trying to test it at all. I do have an https site though. Is there another option.

  6. Paul Clark
    Member
    Plugin Author

    Posted 2 years ago #

    Upgrade to version 0.5.3 (today's update) through the WordPress updater and let me know if that version resolves your issue. It includes my best guess at what is causing your issue.

  7. stayc215
    Member
    Posted 2 years ago #

    I updated and it says in Chrome: So It gives that scary red symbol as if my site it doomed.

    The page at https://virtualstarr.com/ ran insecure content from http://fonts.googleapis.com/css?family=Rock+Salt.
    The page at https://virtualstarr.com/ ran insecure content from http://fonts.googleapis.com/css?family=Siamreap.
    The page at https://virtualstarr.com/ displayed insecure content from http://themes.googleusercontent.com/static/fonts/rocksalt/v3/Q94aHXFHGip10K5uxi1jOD8E0i7KZn-EPnyo3HZu7kw.woff.
    The page at https://virtualstarr.com/ displayed insecure content from http://themes.googleusercontent.com/static/fonts/siamreap/v4/BClNYG4a8JR2g5xzn2BVTg.woff.

  8. Paul Clark
    Member
    Plugin Author

    Posted 2 years ago #

    Re-save the stylesheet to refresh your cache (the CSS needs to be rewritten).

    Appearance > Styles, then "Save Changes".

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.