WordPress.org

Ready to get started?Download WordPress

Forums

Strictly Google Sitemap
[resolved] Cron does not ping search engines (7 posts)

  1. westcoastcontent
    Member
    Posted 3 years ago #

    When using external cron, does not ping search engines

  2. Strictly Software
    Member
    Plugin Author

    Posted 3 years ago #

    How do you know this?

    The same build code runs whether an external or internal cron job is run which will ping SERP once a file exists.

    Can you provide me with the details that show this not to be true please so I can take a look.

  3. westcoastcontent
    Member
    Posted 3 years ago #

    Thank you for getting back to me! Minus the small issues I am seeing, this a superior plugin.

    When I manually run the rebuild, the ping information is detailed on the plugin information screen, but when I look at it after a cron update, no ping information is present.

    Any word on my other two issues? gzip file size and category/tab missing the "/"?

    Thank you
    WCC

  4. Strictly Software
    Member
    Plugin Author

    Posted 3 years ago #

    The PING issue is basically a non issue as whenever the rebuild runs whether through CRON or Manual rebuild the PING is carried out. Just for you I double tested this last night by turning on DEBUG and running the job through a wget command. Checking the Apache access log file also showed an instant visit from googlebot straight after the job had run which seems to be their behaviour whenever a sitemap is re-issued to their system.

    I guess you seem to be expecting to see exactly the same information at the top of the screen when you load the admin page as you do after carrying out a manual rebuild and the plugin doesn't do that. When you visit the admin page the details at the top are just an overview of your current status. When you carry out a manual rebuild I show you all the actions that are carried out during the build. This is why the details of the last PINGs don't appear when you just load the page as I would have to save the actual details of their HTTP requests and status code responses so that they could be shown.

    The category / tag issue was also fixed last night but the gzip issue I need some more info about as it's not to clear from your post what you need me to do regarding that.

    I haven't had a chance to update my own website yet (and only do so every month or so) and I know WordPress is a bit slow in updating their own system even when the code is up to date their display is old.

    Even though on this page >

    http://wordpress.org/extend/plugins/strictly-google-sitemap/

    it shows you under the red download button that I updated the plugin last night (29th March) the button still says "Download Version 1.0.6" even though if you download the zip file the Readme.txt clearly shows its 1.0.7 and the plugin is that version.

    However you can always get the latest copy of any wordpress plugin from the trunk of the relevant SVN repository e.g

    http://plugins.svn.wordpress.org/strictly-google-sitemap/trunk/

    As you can see from the readme.txt file the version is 1.0.7.

    Hope this helps

  5. Strictly Software
    Member
    Plugin Author

    Posted 3 years ago #

    The PING issue is basically a non issue as whenever the rebuild runs whether through CRON or Manual rebuild the PING is carried out. Just for you I double tested this last night by turning on DEBUG and running the job through a wget command. Checking the Apache access log file also showed an instant visit from googlebot straight after the job had run which seems to be their behaviour whenever a sitemap is re-issued to their system.

    I guess you seem to be expecting to see exactly the same information at the top of the screen when you load the admin page as you do after carrying out a manual rebuild and the plugin doesn't do that. When you visit the admin page the details at the top are just an overview of your current status. When you carry out a manual rebuild I show you all the actions that are carried out during the build. This is why the details of the last PINGs don't appear when you just load the page as I would have to save the actual details of their HTTP requests and status code responses so that they could be shown.

    The category / tag issue was also fixed last night but the gzip issue I need some more info about as it's not to clear from your post what you need me to do regarding that.

    I haven't had a chance to update my own website yet (and only do so every month or so) and I know WordPress is a bit slow in updating their own system even when the code is up to date their display is old.

    Even though on this page >

    http://wordpress.org/extend/plugins/strictly-google-sitemap/

    it shows you under the red download button that I updated the plugin last night (29th March) the button still says "Download Version 1.0.6" even though if you download the zip file the Readme.txt clearly shows its 1.0.7 and the plugin is that version.

    However you can always get the latest copy of any wordpress plugin from the trunk of the relevant SVN repository e.g

    http://plugins.svn.wordpress.org/strictly-google-sitemap/trunk/

    As you can see from the readme.txt file the version is 1.0.7.

    Hope this helps

  6. westcoastcontent
    Member
    Posted 3 years ago #

    WP still reports as v1.06, I was running v1.05 but the download would not fuction as it indicated it was already installed, so I deleted and reinstalled the pluging and it does infact report v1.07.

    Category / Tag issue resolved :-)

    Ok, have not confirmed via debug, but understand you are saying the information at the top of the screen does not/will not reflect it (might want to consider updating that)

    gzip issue is still present, google will not process due to file size.

    While the actual bite count is only 438K, the size reported in the gzip file is 972 206 640 causing it to fail on google. To verify simply download and open in your qzip program and check the file properties.

    http://freeonlinecaradvice.com/sitemap.xml.gz

    Thank you for your continued support!

    - WCC

  7. Strictly Software
    Member
    Plugin Author

    Posted 3 years ago #

    I think I have fixed the GZIP problem which was due to the gzencode method I was using which for some reason meant the gzunzip couldn't be performed.

    I have changed the code to use another method and created a gzip version of a couple of sitemaps that have been submitted to google - pinged automatically during the CRON job :) - and they have been accepted by Google Webmaster Tools without any problem e.g it shows a tick not a cross next to the gzip version.

    I have updated the code on WordPress SVN (still version 1.0.7) and the readme.txt file should show this attempted fix in the details for this version.

    So re-download the latest file and try it again and let me know if you have any problems

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic