WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Stray Random Quotes] Can't make source urls links (6 posts)

  1. scarlettibis
    Member
    Posted 5 years ago #

    I’ve upgraded to v1.7 (on WP 2.7) and am unable to make the source (or author for that matter) a link. Also, if I include a link in a quote itself then all the text below (different quotes) becomes that link.

    I need to know how to make the source (which are urls) links. Can you please help? Here’s the page on my site where all quotes are listed: http://perfectcirclemedia.com/contact-us/testimonials

    Thank you so much for your response.

  2. corpodibacco
    Member
    Posted 5 years ago #

    Hi, I am the author of Stray Random Quotes. That particular feature works without a problem on my end. Maybe you are writing the link wrong? could you give an example of a link to an author as you wrote it down in the settings page?
    thanks

    p.s. If everything becomes a link after the link (when you put a link inside a quote) it means that the link tag is not closed. A link starts with a <a href= and ends with an </a>. When you create a link, make sure you have selected a piece of text in the quote before you click on the "link" button.

  3. scarlettibis
    Member
    Posted 5 years ago #

    Hi ~ Thanks for writing back, I do heart your plugin. In the last version, there was an option to select that the source & author would be made links. Now, I don't know how to make them links. If you look at the page where the quotes are listed: http://perfectcirclemedia.com/contact-us/testimonials you can see that the sources is listed as a url.

    Here's what I've tried:

    1. Making the source/author a link with the a tags inside the fields called "author" & "Source" on the page: "manage quotes" or "add quotes". The result of this is that those fields disappear and all text below it (next quotes in the list) becomes a link (opens a new tab, but doesn't go to any url)

    2. Under "settings" I've tried surrounding the "source" with html tags. Here's a screenshot: http://perfectcirclemedia.com/quote.jpg The result is that all the quote sources disappear.

    3. Under "settings" I've tried adding the %SOURCE% text you mention, and the result is they are all made clickable, but open to: http://mother's-kitchen-l.a./ (the source of the 1st quote, and not an actual link). Here's a screenshot: http://perfectcirclemedia.com/quote2.jpg

    I was hoping that somehow I'm not seeing the setting selection to simply make all the sources links. However, it seems that's not the case? Can you please tell me how to make sources links (that open to the correct url).

    Thanks

  4. corpodibacco
    Member
    Posted 5 years ago #

    Hey scarlettibis.

    Problem n.1: No, you cannot make a link in the source or author fields. Only inside the quote field. Links to sources or authors are possible only following a general pattern using the settings page.
    Anyway, if it is not too hard to implement there is no reason why this function should not exist. I'll consider it for the next release 1.7.2.

    Problem n.2: Probably the settings page is not very clear. Anyway, you don't have to add the "a href" or anything like it to the field on the left. Use instead only the fields on the right (those under which is written "you can link...") and only by adding the URL and optionally the variables. All the rest will be done automatically.

    Problem n.3: Your example obviously can't work because of the apostrophe which cannot exist in a URL. There are forbidden characters in a URL that may be generated by the %SOURCE% variable and I hadn't considered this. This is actually a bug and I will solve it with version 1.7.2, and thanks for pointing it out.
    That said, http//%SOURCE% would not work anyway. Consider those two examples with google and wikipedia I have written in the page. It must be a proper link, something at least like http://%SOURCE%.com or http://somedomain.com/%SOURCE%

    Hope this clarifies your questions...

  5. corpodibacco
    Member
    Posted 5 years ago #

    Correction about problem 1: You do can add a link in the author or source links. Write the entire link there, as in: <a href="link to the goes here">source goes here</a> and leave empty the url fields in the setting page. I could make it easier by adding a "link" button to the source or author fields in the next release.
    This should further clarify the other problems, since this is the only way to have a specific link for every single quote source or author.

  6. scarlettibis
    Member
    Posted 5 years ago #

    corpodibacco ~

    You've been very generous with your time, and I thank you kindly. The results I'm after (each source having a unique url) is achieved with your correction to problem #1. Of course, I should have written out the full URL. I think that it was my lack of understanding about the %SOURCE% variable that created some confusion, and also that I thought the last version of the plugin had a setting selection for "make sources links" however, I'm not sure.

    Again, thank you so much for a great plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic