WordPress.org

Ready to get started?Download WordPress

Forums

Stout Google Calendar
[resolved] Won't save calendar (13 posts)

  1. jimmerd
    Member
    Posted 3 years ago #

    I've tried this plugin but it's not saving the calendar at all. At first, I thought it might be the PHP version. My host was using 4.something and I upgraded to 5.2.12. Still not saving.

    I paste the embed code, give it a title, then click ADD CALENDAR.

    I get a message: Calendar successfully added.

    But there's nothing below "Saved Calendars".

    http://wordpress.org/extend/plugins/stout-google-calendar/

  2. jlarson
    Member
    Posted 3 years ago #

    Same problem here.

  3. jlarson
    Member
    Posted 3 years ago #

    The table name is hard coded as wp_stoutgc, so won't work if you have a different prefix, including MU installations. Need to change the code to get the prefix from ($wpdb->prefix). Thanks for the nice plugin, though.

  4. jimmerd
    Member
    Posted 3 years ago #

    Perfect! Thanks jlarson.
    I just did a search and replace and re-uploaded (change wp-stoutgc to myprefix_stoutgc).
    Works fine now.

    Seems like it should be an easy fix for the plugin in next version, yes?

  5. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Everyone,

    I have released an update (1.0.2) to fix this problem. Thanks for pointing out the issue and sorry for the trouble.

  6. fathoni
    Member
    Posted 3 years ago #

    I upgraded the plugin to 1.0.4, saved the calendar successfully and these calendars listed in Saved Calendars. Unfortunately, these calendars are not present in the widget's calendars list. I attempted to post it as a shortcode, but it keeps giving "Google calendar embed code appears to be incorrect" warning. The preview runs correctly though. I run WP in localhost. Is there any way to solve this? i tried to change the prefix as mentioned above, but it doesn't work.

    Any help would be appreciated, thank you.

  7. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    I made several quick fixes yesterday and realized there was a problem with the embed code in 1.0.4 after the release. Please upgrade to the latest version - 1.0.5.

  8. fathoni
    Member
    Posted 3 years ago #

    Thanks! it works now. Actually when i was activating the plug-in directly after installation, it gave an error warning, but it can be activated from WP's plug-in page smoothly.

    And probably, just a suggestion, you could give the language options on iframe setting by adding 'hl=xx' to Google Calendar's link in iframe? I'm accessing my web in Korea, and by default, the calendar is in Korean, while most of the readers is using Indonesian and English.

    Thank you!

  9. jameswirth
    Member
    Posted 3 years ago #

    Hey Stout -- I'm having a slightly different issue. Installed 1.0.6 and activated plug-in, pasted my iframe and saved and it says successful; however, when I try to preview calendar I get the following two messages:

    Warning: main(Services/JSON.php) [function.main]: failed to open stream: No such file or directory in /home/content/07/6575107/html/wp-content/plugins/stout-google-calendar/gcalendar-wrapper.php on line 295

    Fatal error: main() [function.require]: Failed opening required 'Services/JSON.php' (include_path='.:/usr/local/lib/php') in /home/content/07/6575107/html/wp-content/plugins/stout-google-calendar/gcalendar-wrapper.php on line 295

    Suggestions?

  10. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    Hi James,

    Open the gcalendar-wrapper.php file in the stout-google-calendar directory. Go to line 295 and change:

    require_once('Services/JSON.php');
    to this:
    require_once('JSON.php');

    Looks like I accidentally changed this on an update I made to a previous release. Let me know if this works for you. I'll update the plugin to fix this bug.

    Thanks

  11. jameswirth
    Member
    Posted 3 years ago #

    Thanks for the fast response -- I did the replace and confirmed in the editor that it had changed, but I'm still getting the same error (now on the new directory):
    Warning: main(Services/JSON.php) [function.main]: failed to open stream: No such file or directory in /home/content/07/6575107/html/wp-content/plugins/stout-google-calendar/gcalendar-wrapper.php on line 295

    Fatal error: main() [function.require]: Failed opening required 'Services/JSON.php' (include_path='.:/usr/local/lib/php') in /home/content/07/6575107/html/wp-content/plugins/stout-google-calendar/gcalendar-wrapper.php on line 295

    I tried deleting the calendar and adding it again to no avail. Also tried deactivating and re-activating the plug-in. Nothing.

    Thoughts?

  12. jameswirth
    Member
    Posted 3 years ago #

    OOPS! My error, I edited the default file. WORKS! Do I need to change it back on the stout-google-calendar.php file to 'Services/?

    Thanks again for the fast response -- James

  13. averagejoe76
    Member
    Posted 2 years ago #

    I am having the problem fathoni was having 11 months ago with the 1.4 version, yet I am running 1.2.3. I've installed the plugin, I am looking at it in the preview, I've made test appointments that show in the preview, but I get this message on my website. "Google calendar embed code appears to be incorrect." Any ideas? I'd like to use this plugin since the person I am helping with the website is a big google apps user.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic