WordPress.org

Ready to get started?Download WordPress

Forums

Stout Google Calendar
SSL certificate problem (25 posts)

  1. vikjohn
    Member
    Posted 3 years ago #

    I updated to the lastest version of the calendar plugin and this morning I find this error:
    <<The following error(s) occurred: http_request_failed
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed>>

    I've uninstalled, deactivated, re-done everything with the same results.
    I need this working before a demo on next Tuesday!! Help please....

  2. vikjohn
    Member
    Posted 3 years ago #

    Tried downgrading the plugin and that did not work.

  3. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    Use the latest version, 1.2.3, and remove the line below in the gcalendar-wrapper.php file. It's around line 47:

    die('The following error(s) occurred: '.$errors);

    Let me know if this works

  4. vikjohn
    Member
    Posted 3 years ago #

    I re-upgraded and made the fix; now it says "Array"

  5. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry, please try this and let me know what you get. Basically change die to echo

    echo 'The following error(s) occurred: '.$errors;

  6. vikjohn
    Member
    Posted 3 years ago #

    Made the change:

    The following error(s) occurred: http_request_failed
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    Array

  7. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    OK, I was hoping it was just a warning and the rest of the script would continue but I guess that's not the case. I don't have a quick fix for this issue and will have to look into it more later on. Can you please post your Google Calendar embed code so I can verify all looks good?

  8. Droidex
    Member
    Posted 3 years ago #

    <iframe src="https://www.google.com/calendar/embed?showTitle=0&showPrint=0&showTabs=0&showCalendars=0&mode=AGENDA&height=500&wkst=1&bgcolor=%23ffffff&src=juntalocal%40fallesdenia.com&color=%23182C57&ctz=Europe%2FMadrid" style=" border-width:0 " width="300" height="500" frameborder="0" scrolling="no"></iframe>

  9. vikjohn
    Member
    Posted 3 years ago #

    <iframe src="https://www.google.com/calendar/embed?showTitle=0&showPrint=0&showTabs=0&showCalendars=0&showTz=0&mode=AGENDA&height=218&wkst=2&bgcolor=%23FFFFFF&src=refdesk%40drury.edu&color=%23182C57&src=en.usa%23holiday%40group.v.calendar.google.com&color=%23691426&ctz=America%2FChicago" style=" border-width:0 " width="323" height="230" frameborder="0" scrolling="no"></iframe>

    Thanks for looking into this... V

  10. DTSSSE
    Member
    Posted 3 years ago #

    Hi ,

    I,ve got the same error : [ The following error(s) occurred: http_request_failed
    SSL certificate problem, verify that the CA cert is OK. Details: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed ]
    after updating to WP 3.1,

    Google Calendar iframe embed code:

    <iframe src="http://www.google.com/calendar/embed?showTz=0&showTabs=0&showPrint=0&mode=AGENDA&hl=fr&src=utl.libourne%40gmail.com&ctz=Europe/Paris" style=" border:solid 1px #777 " width="700" height="450" frameborder="0" scrolling="no"></iframe>

    Thanks for looking into this too, DTS

  11. heddle
    Member
    Posted 3 years ago #

    Same problem here. Must be something to do with the WordPress 3.1 update.

  12. HLISM
    Member
    Posted 3 years ago #

    Same Here - New Site Clean Install

  13. DTSSSE
    Member
    Posted 3 years ago #

    Hi !

    I've red this at the botttom of the settings page of Stout Google calendar :

    This plugin requires:
    WP_Http : WP_Http present. Looks good.

    What does that mean ?

  14. schwenkbl
    Member
    Posted 3 years ago #

    I am experiencing the error as well.

    I manually added code togcalendar-wrapper.php to send the request with sslverify set to false and it worked. Of course that doesn't tell you anything you don't know.

    Any updates on this issue?

  15. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    @schwenkbl - If you have a patch please let me know and I'll be happy to look at it. You can send it to sgc@stoutdesign.com

    I have not had free time to work on a fix for this but will reply to this thread once I do. Thanks

  16. vikjohn
    Member
    Posted 3 years ago #

    I tweakded the calendar on google to get it to look like I want and then just copied the iframe code from Google to a text widget and everything works fine.

  17. schwenkbl
    Member
    Posted 3 years ago #

    @stoutdesign: i'm not sure it's a safe patch for people b/c i'm basically overriding the SSL certificate validity check in WP's HTTP Request class. do you think this could be a potential security risk, even though the SSL is coming from an obviously-trusted source (google)?

    based on the little time i looked at it, i think the error is coming from WP's HTTP code, not yours. but i don't know b/c i've never looked at WP code before last night

  18. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    @schwenkbl - I don't know all the internals of the WP_Http class but do think in this specific instance (since we're dealing specifically with Google calendar), bypassing sslverify probably isn't that big of a deal. I would love it if someone else with more experience using this class could help. I was thinking that I can add a global setting in the next release to disable the sslverify option if needed.

    For everyone else out there, you can try changing line 40 of the gcalendar-wrapper.php from this
    $result = $request->request($calUrl);
    to this

    $result = $request->request($calUrl, array('sslverify' => false));

    If this works for any of you, please let me know so I can roll this into a future release. I can't replicate the issue on my servers and could use the help testing this out.

    @vikjohn - Glad to hear the workaround did the trick for you. The aim of this plugin is to override the color scheme or 'skin' the calendar for a site. The default Google calendar embed code doesn't allow this so I would appreciate if you give the code above a try and let me know your results.

  19. DTSSSE
    Member
    Posted 3 years ago #

    Hello from France :

    I try " $result = $request->request($calUrl, array('sslverify' => false));"

    It works.
    Thanks
    DTS

  20. RoteZora
    Member
    Posted 3 years ago #

    @stoutdesign:
    Your suggestion works also for me:

    For everyone else out there, you can try changing line 40 of the gcalendar-wrapper.php from this
    $result = $request->request($calUrl);
    to this

    $result = $request->request($calUrl, array('sslverify' => false));

  21. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    @RoteZora and DTSSSE - great to hear it works for you. I'll roll an option into the next release to disable sslverify. I'll post back here when it's ready.

  22. MoneyHacker.com.ua
    Member
    Posted 3 years ago #

    For everyone else out there, you can try changing line 40 of the gcalendar-wrapper.php from this
    $result = $request->request($calUrl);
    to this
    $result = $request->request($calUrl, array('sslverify' => false));

    Me help too
    Thanks

  23. wpmirwin
    Member
    Posted 2 years ago #

    This fix:

    "$result = $request->request($calUrl, array('sslverify' => false));"

    also worked for me.

    Thanks!

  24. Taylor Dewey
    Member
    Posted 2 years ago #

    The same fixed worked for me.

    If it helps it was on line 36 (plugin v. 1.2.3, WP v. 3.2b2, running on localhost via MAMP. PHP 5)

  25. khrizart
    Member
    Posted 2 years ago #

    It works for me... thanks :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic