WordPress.org

Ready to get started?Download WordPress

Forums

Stout Google Calendar
[resolved] Plugin won't appear on Page (7 posts)

  1. theapi5
    Member
    Posted 3 years ago #

    I'm using the Stout Google Calendar to list events. The preview is fine but it won't show on the page when I copy and paste in the shortcode that it gives me.

    '[stout_gc id=1]' is all i'm putting in. I only have one calendar that's being shown, so there's no confusion in feeds.

    My website is http://www.theapiarycorp.com.

  2. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    I looked at your site and I do not see where the Stout Google Calendar is being used. Can you set up a temporary post/page with the shortcode included?

  3. theapi5
    Member
    Posted 3 years ago #

    Thanks for getting back to me so fast. Turned out the issue was with my other plugins. I deactivated a bunch and I found the culprit!

  4. calisuri
    Member
    Posted 3 years ago #

    theapi5 - what was the culprit?

  5. stoutdesign
    Member
    Plugin Author

    Posted 3 years ago #

    After some investigating it appears that wp-minify is rewriting the urls for the CSS and JS files. In order to get around this you can:
    1) disable wp-minify (probably should do this at first anyway - just to verify this is in fact the problem you are having)
    or
    2) Add the CSS and JS files to the "files to exclude" in the wp-minify settings. Here's how you do this:

    1. Look at the generated source of the iframe that is displaying a blank page. You need to look for the CSS and JS file names. These are unique to each calendar so you're own your own for this. Eg, <rel='stylesheet' href='http://www.example.com/wp-content/plugins/wp-minify/min/?f=9278a6f3de5f9e54f2aee4jgu48djw2eembedcompiled_fastui.css&b=torwp&m=0' type='text/css' media='screen' />
    2. Add the css file name, in this example 9278a6f3de5f9e54f2aee4jgu48djw2eembedcompiled_fastui.css to the "CSS files to exclude.." in wp-minify
    3. Get the JS file name from the generated source, eg, <script type='text/javascript' src='http://www.theonering.net/torwp/wp-content/plugins/wp-minify/min/?f=9278a6f3de5f9e54f2aee4jgu48djw2eembedcompiled__en.js&b=torwp&m=0'></script>
    4. Add the JS file name, in this example 9278a6f3de5f9e54f2aee4jgu48djw2eembedcompiled__en.js to the "JS files to exclude.." in wp-minify

    Repeat these steps for every saved Stout Google Calendar you are using on your site. Do NOT copy and paste the CSS and JS file names above because it will NOT work for your site.

    Hope this helps

  6. CrouchingBruin
    Member
    Posted 3 years ago #

    I'm having the same problem, except I don't have any plugins active except for this one. Previewing the calendar in the Stout Google Calendar options page, the calendar shows up fine (I had the SSL problem earlier but edited gcalendar-wrapper.php as explained in a different post). I entered just the [stout_gc id=1] shortcode on a new page. But the calendar doesn't show up on the site. I've disabled all other plugins with no changes.

    http://vhbt.geefamily.net/index.php/calendar
    WP Version 3.1.2
    Plugin Version 1.2.3

  7. CrouchingBruin
    Member
    Posted 3 years ago #

    Nevermind, I figured it out. I had selected a template for the page that caused it not to be displayed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic