WordPress.org

Ready to get started?Download WordPress

Forums

Stout Google Calendar
php warnings running plugin (1 post)

  1. evelk
    Member
    Posted 2 years ago #

    I get many errors (warnings?) when using the stout-google-calendar plugin (1.2.3) on our Windows server, running Apache 2.2:

    PHP Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(D:\home\martijn.eve-software.com\WWW\wordpress/wp-content/plugins/D:\home\martijn.eve-software.com\WWW\wordpress\wp-content\plugins\stout-google-calendar/languages/stout-gc-en_US.mo) is not within the allowed path(s): (d:\home\martijn.eve-software.com) in D:\home\martijn.eve-software.com\WWW\wordpress\wp-includes\l10n.php on line 334

    I changed some lines in the code:

    \wordpress\wp-content\plugins\stout-google-calendar\stout-gc-widget.php

    old code:
    $plugin_dir = dirname(__FILE__);
    load_plugin_textdomain( 'stout-gc','wp-content/plugins/'.$plugin_dir, $plugin_dir);

    new code:
    $plugin_dir = dirname(plugin_basename(__FILE__));
    load_plugin_textdomain( 'stout-gc', false, $plugin_dir);

    \wordpress\wp-content\plugins\stout-google-calendar\stout-google-calendar.php

    old code:
    load_plugin_textdomain( 'stout-gc',null, dirname(__FILE__).'/languages/');
    new code:
    load_plugin_textdomain( 'stout-gc',null, dirname(plugin_basename(__FILE__)).'/languages/');

    Can you implement these changes into the next release of the plugin?

    Regards,
    Edwin

    http://wordpress.org/extend/plugins/stout-google-calendar/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic