WordPress.org

Ready to get started?Download WordPress

Forums

Stop Spammers
[Plugin: Stop Spammer Registrations Plugin] New Version 3.8 - please report problems (20 posts)

  1. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I just released the 3.8 version of the plugin.

    As usual there are a great many changes, many of which affect how the plugin operates.

    Please report immediately if there are any problems on your site so I can get a fix out.

    The plugin is getting very large and complicated with many options. I have tested on my sites for two weeks without issue, but there are so many configurations out there that I can't be certain that I've found all the problems.

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

  2. artmuns
    Member
    Posted 1 year ago #

    Been working fine up to now but getting these errors:

    ERROR: Invalid email address submitted!
    ERROR: Slow down; you move too fast.

    Tried disabling some of the e-mail and red herring options but no joy. Have disabled for now

  3. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Artmus,

    I don't have these words in my plugin.

    The messages are coming from StopForumSpam.com

    You are trying to report spam that did not have an email address and you are trying to report spam too fast. They have limits on how soon you can report spam again after a report.

    Don't report spam and the plugin will work fine.

    Be careful reporting spam. Make sure there is a valid email and that you don't report spam too fast.

    Keith

  4. artmuns
    Member
    Posted 1 year ago #

    I disabled the StopForumSpam.com option and there is a valid e-mail address. Still getting the same error. Plugin worked fine before the latest update.

  5. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    The link for reporting spam is still there. Disabling the SFS option means that it will not check the sfs database when a spammer tries to leave spam. You only get the message when you check or report spam manually from the comments moderation page.

    Do not check or report spam from comments moderation and it will be fine. For some reason, SFS is not letting you check or report spam. The plugin will work preventing spam. You do not need to report or check spam, the plugin will do it for you every time a spammer hits your site.

    Keith

  6. artmuns
    Member
    Posted 1 year ago #

    I'm not checking or reporting spam manually. This error occurs when a visitor tries to leave a reply on a forum. Website is http://www.musiclibraryreport.com.

    Plugin is currently disabled.

    Thanks for your help.

  7. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Artmuns,

    Uncheck "Check IP on xmlrpc.php:".

    It appears that your theme's comment system is using ajax calls to process the comments. The responses are coming back from the the call to sfs in xmlrpc. I am surprised that unchecking the check sfs db did not stop this from happening. I will look at the code again.

    Keith

  8. artmuns
    Member
    Posted 1 year ago #

    I unchecked "Check IP on xmlrpc.php:" but it did not fix the problem.

  9. artmuns
    Member
    Posted 1 year ago #

    Where can I get the previous version as that was working well for me.

    Thanks

    Art

  10. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Try

    http://downloads.wordpress.org/plugin/stop-spammer-registrations-plugin.3.7.zip

    I wish I had more information about this.

    Keith

  11. artmuns
    Member
    Posted 1 year ago #

    Thanks Keith. Just installed 3.7 and it works fine.

    Maybe it's a conflict with one of my other plugins. It's an active site so I don't want to start disabling plugins to track it down. There are 31 active plugins on the site.

    Stop Spammer is a great plugin and I did buy the hardcover edition of your book.

    Thanks again for your help!

    Art

  12. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I am hoping that someone else has a similar problem so that I can track down the root problem. I don't get it on my site and over 1,000 people have installed the 3.8 version without anyone complaining. It certainly has something to do with the stopforumspam.com database because all the messages come from them, but I the plugin never displays the results. I am at a loss.

    Thanks for buying the book, but did you read it?????

    Keith

  13. artmuns
    Member
    Posted 1 year ago #

    I didn't try 3.8 with comments. Maybe a conflict with the BBpress forum plugin as I was getting it on replies to topics.

    Haven't read the book yet but will.

    Thanks again Keith.

    Art

  14. Jacob Schweitzer
    Member
    Posted 1 year ago #

    I've been having the same problem, quite embarrassing so we turned off the plugin. When a user tries to register (even a white-listed user) the plugin gives the error "Please verify your e-mail address". I even disabled stop forum spam from checking the email address (so supposedly it only check the IP), disabled the option to check long email addresses, and disabled the option to check "disposable emails" (whatever that means). Still didn't work..

  15. Jacob Schweitzer
    Member
    Posted 1 year ago #

    By the way, I'm using BuddyPress and I checked the portion of the code where the error is coming from. It comes after a check for a valid email address using the WordPress function is_email . So the email address must getting messed up by the plugin prior to this check, which is why it is throwing the error.

  16. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I stopped hooking the is_email function, but in the last release I put the sanitize_email hook in that is similar. I don't think that it is really needed, but I was trying to fix it so that MU registrations where checked in some situations where they were letting in spammers.

    I have taken out the sanitize hook and upload it so that it can be downloaded from the beta page.

    http://www.blogseye.com/beta-test-plugins/

    Keith

  17. artmuns
    Member
    Posted 1 year ago #

    Hi Keith,

    Just installed this today and that fixed the problem.

    Thanks again!

    Art

  18. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Good news Artmuns,

    I don't need the the BB check, then. I will leave the other changes in and 3.9 will be good, at least for this problem.

    Thanks for the help,

    Keith

  19. artmuns
    Member
    Posted 1 year ago #

    Also I believe you made some changes for PayPal? I found (in the older version) if I unchecked "Check for missing HTTP_USER_AGENT:" it solved my PayPal problems. I was getting and e-mail from PayPal that some process wasn't getting completed even though transactions were going through without a problem.

  20. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I whitelisted all of the paypal ips so that there is no checking when paypal hits the site. I think that this will stop paypal problems.

    Keith

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.