WordPress.org

Ready to get started?Download WordPress

Forums

Stop Spammers
[Plugin: Stop Spammer Registrations Plugin] Locked out of my own blog ! (68 posts)

  1. canucktunes
    Member
    Posted 2 years ago #

    Unable to login because of your plugin. Tried to delete your plugin manually via FTP but unable to do so.

    VERY annoyed.

    http://wordpress.org/extend/plugins/stop-spammer-registrations-plugin/

  2. Karesansui
    Member
    Posted 2 years ago #

    Me to...

    Access Denied
    This site is protected by the Stop Spammer Registrations Plugin.

    Annoyed you say ! Sorry to say but to me this is really unacceptable !!

  3. Karesansui
    Member
    Posted 2 years ago #

    For now you can remove the stop-spammer-registrations.php file from the plugin root. That will do !
    Better save a version before you do see, you never know !

  4. canucktunes
    Member
    Posted 2 years ago #

    Found out my version. 2.8.6. Unable to update because of my host. :(

  5. canucktunes
    Member
    Posted 2 years ago #

    Tried to remove "stop-spammer-registrations.php". Can't.

  6. Karesansui
    Member
    Posted 2 years ago #

    Well my update was correct.. but with the very same problem.

    After removing the file stop-spammer-registrations.php WordPress-admin will deactivate it. Then if you place the file back, the plugin is in the list but inactive !

  7. Karesansui
    Member
    Posted 2 years ago #

    Then you need to change the access settings for the file or better, logon to your host as admin and delete it there.

    .... and try closing the session with the message !

  8. rsavoia
    Member
    Posted 2 years ago #

    I upgraded last night and attempted to log in this morning. I am locked out of my own blog!! I agree, this is unacceptable. Doesn't anyone test these plug-ins before they are released?

    I am NOT happy about this.

  9. metapha
    Member
    Posted 2 years ago #

    Same here. I renamed the folder / directory of the plugin. Hope that the bug will soon be fixed!

  10. chimesfreedom
    Member
    Posted 2 years ago #

    I had the same problem this morning after updating the plugin yesterday, and I could not access my own site. Any suggestions?

  11. metapha
    Member
    Posted 2 years ago #

    you can simply rename the folder / directory of the plugin on your server to deactivate it:
    for example:
    wp-content/plugins/stop-spammer-registrations-plugin
    to
    wp-content/plugins/stop-spammer-registrations-plugin_old

  12. kpgraham
    Member
    Plugin Author

    Posted 2 years ago #

    I am checking this out.

    Did anybody get back in and check the reason why they were blocked? The log should show a reason. If you get back in and activate the plugin you should be able to view the history and then disable the plugin.

    I cannot reproduce this on my blogs.

    I will release an update as soon as I can.

    Keith

  13. metapha
    Member
    Posted 2 years ago #

    my IP address was blocked.

    I managed to get back in by renaming the directory, logging in, reactivating the plugin and adding my IP address to the white list. My IP address is not listed for spam, I checked on http://www.stopforumspam.com

  14. Karesansui
    Member
    Posted 2 years ago #

    If you get back in and activate the plugin you should be able to view the history and then disable the plugin.

    Well sorry Keith, but I am not going to take such risk.

    I did what I described above, remove stop-spammer-registrations.php, Logon to WP, then WP finds a problem and deactivates the plugin (it is then not in the plugin-list), moved back the file stop-spammer-registrations.php and then it is also back in the WP list of plugins, deactivated.

    I am almost sure that when I activate it I will be locked out again.

    @chimesfreedom see my advice a fw post back. That worked for me.

  15. chimesfreedom
    Member
    Posted 2 years ago #

    Thanks @Karesansui. I had to call my hosting company and they walked me through the process of getting access back to my site (which was pretty much what you suggested): (1) We logged into the cpanel and opened File Manager. (2) From there we opened the file "wp-content," and then (3) opened the file "plugins," where you can scroll down to the plugin's name. (4) Then we changed the name of the stop spammer registration plugin (by adding "_old" to the name, but you can change it however you like).

    Now I can access my site again. The plugin is listed as deactivated and if I reactivate it, I go back to not having access to my site and have to go through the process again. I guess I won't be using this plugin until the bug is fixed.

  16. wall
    Member
    Posted 2 years ago #

    Looks like i'm gonna stay at v2.20 for now...

  17. kpgraham
    Member
    Plugin Author

    Posted 2 years ago #

    I am now locked out of my own blog and I am getting reported as a spammer from StopForumSpam.

    The site http://www.stopforumspam.com appears to be compromised and it may be that everyone is getting listed as blocked.

    I will revert to 2.20 and see what the difference is.

    Keith

  18. folgerj
    Member
    Posted 2 years ago #

    Well Keith, I suggest you ask for a list of plugins from all of us who are using your plugin.
    This way you can see if there is a common plugin that we are all using that you aren't.
    I'm also looking for a log but I'm not sure what I'm looking for. If you can direct me to a log file then I'll see what I can tell you.
    I've looked through the blog root directory and a few sub directories for logs that might tell me what it was doing but the plug-in directory for stop spammer is gone once I removed the PHP file from the plug-in route. I did download the file in question to my desktop just in case there is information in that file that I can use.

  19. Karesansui
    Member
    Posted 2 years ago #

    I checked on stopforumspam.com but neither my IP (v4), nor email nor userid are registered.

    So then it may be your IP Keith if you use that in any way in the plugin.

  20. Ovidiu
    Member
    Posted 2 years ago #

    btw. the history looks like this:

    2012/05/22 13:49:09 -- 196.215.110.106 -- /wp-login.php?redirect_to=http%3A%2F%2Fsasha.zice.md%2Fwp-admin%2Fedit-comments.php%3Fcomment_status%3Dmoderated&reauth=1 SFS, 2012-05-22, 255; My journal: c(183), p(1), s(0)

    and the reason for this block is: SFS, 2012-05-22, 255;

  21. Ovidiu
    Member
    Posted 2 years ago #

    oh, and for all the others saying that being locked out is unacceptable, maybe reconsider using this type of plugin?
    I mean the scope of the plugin is to block access based on IP, email and spammer databases, i.e. stopforumspam, projecthoneypot, etc. so what happened to you is exactly what will happen to other users/visitors that are i.e. using IPs that were misused.

  22. Ovidiu
    Member
    Posted 2 years ago #

    quick fix:

    I have deactivated StopForumSpam for now until the plugin author sorts this out.

    To do this I changed these options:
    Deny spammers found on Stop Forum Span with more than 9999 incidents, and occurring less than 1 days ago.

    And then purged the cache!

    I know I have weakened my protection but this is better than disabling the whole plugin!

  23. kevinff
    Member
    Posted 2 years ago #

    Same here.
    Didn't try to disable deny spammers, but i disabled checks at login.
    In the admin page i had this written for my IP "cached bad ip".

  24. Ovidiu
    Member
    Posted 2 years ago #

    yes, it says: "cached bad IP" now go further up in the history and look for the first block for that IP or simply empty the cache and get blocked again, then go back and check the reason again.

    Btw, how did you do this: " i disabled checks at login" - I can't find an option for that?

  25. kevinff
    Member
    Posted 2 years ago #

    Yes unfortunately we cannot do that, had to comment the lines in the plugin :(

    Tried to disable SFS and re-check login/signup, and it seems to work thx.

  26. Ovidiu
    Member
    Posted 2 years ago #

    :-) same here, I actually asked the author to give us an option of what the plugin is protecting: Comments/Registrations/Logins as I don't need/want to protect Logins...

    Great to see I am not the only one who'd like to have that feature ;-)

    P.S. 3.1 is out and it seems to have fixed the problem!

  27. kpgraham
    Member
    Plugin Author

    Posted 2 years ago #

    I will add the options to check events, and an option to disable the sfs check.

    Ovidiu had a bunch of suggestions that I will try to implement soon.

    I will try to finish up the new features and have a new version out soon.

    I am so sorry about the issues. I swear that I tested logging in and out over the weekend and I had not problem. Suddenly SFS is reporting me as a spammer and evidently everyone else. It is interesting that everyone gets reported as having 255 days as the frequency.

    Please note that I never expected this to be used by more than a few people. I wrote it for myself to prevent registrations on my MU site. I am amazed and gratified by the number of people using the plugin and I hope that it will work without problems again.

    Keith

  28. metapha
    Member
    Posted 2 years ago #

    Thanks for the quick bug fix and for providing such a useful plugin for free :-)

  29. chimesfreedom
    Member
    Posted 2 years ago #

    Yes, thanks Keith for the plugin and for being so responsive.

  30. folgerj
    Member
    Posted 2 years ago #

    Well once I deleted the php files that was mentioned earlier this morning I had no files that I could see so I have no history to look through. I will re-install the plugin as it completely disappeared from my site. I've come to rely on this plugin to keep the majority of the spammers at bay.

    Thanks Keith for a really good plugin...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.