WordPress.org

Ready to get started?Download WordPress

Forums

Stella plugin
[Plugin: stella plugin] menu's don't translate? (8 posts)

  1. Anointed
    Member
    Posted 1 year ago #

    I just went to your pro demo page, chose all the languages and noticed that the menu links don't change...

    Why?

    If I have used strings on everything in my entire install, themes, plugins, etc, then what else doesn't translate?

    http://wordpress.org/extend/plugins/stella-free/

  2. Ruslan.Khakimov
    Member
    Plugin Author

    Posted 1 year ago #

    Are you sure about first issue?
    At english language "Testing page" have an "http://demo.theme.fm/stella/71-2/" link, but if I choose italian -
    "http://demo.theme.fm/stella/it/71-2/"
    About second question. You can translate your strings with Stella API. Look at this tutorials http://theme.fm/category/tutorials/

  3. Anointed
    Member
    Posted 1 year ago #

    http://demo.theme.fm/stella/it/
    The button text in the menu even on the italian page above says 'testing page, Hello'.

    I realize the links themselves are changed, but the front-end display text is not changing. That's kind of a problem no?

  4. nairox
    Member
    Posted 1 year ago #

    Hi... I'm getting this error

    Warning: Missing argument 2 for Post_Localizer::localize_title() in /home/hacerdin/public_html/catalizadores.info/wp-content/plugins/stella-free/classes/class-post-localizer.php on line 186

    Am i missing something on the configuration?

    Thanks

  5. Anointed
    Member
    Posted 1 year ago #

    I don't know. It's the official demo link, not my website.

  6. Ruslan.Khakimov
    Member
    Plugin Author

    Posted 1 year ago #

    Anointed, to localize menu you must visit appearance -> menus. If menus labels empty (for some language) Stella get value from default language.
    So, just fill menus labels.

    nairox, can you tell more detail how you get this message?

  7. yogafool
    Member
    Posted 1 year ago #

    some problem as nairox :(
    http://www.yogafool.net

  8. Ruslan.Khakimov
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    It looks like your slider or theme don't send post ID to the
    the_title() function correctly. It need to research this problem.As a
    quick solution change function loclize title to this:

    function localize_title( $title, $id = ''){
    if( '' == $id) return '';
    if ( STELLA_CURRENT_LANG != STELLA_DEFAULT_LANG ){
    $title_new = get_post_meta( $id, '_title-' . STELLA_CURRENT_LANG, true );
    if ( '' != $title_new || ! $this->use_default_lang_values )
    return $title_new;
    }
    return $title;
    }

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.