WordPress.org

Ready to get started?Download WordPress

Forums

Stella plugin
[Plugin: stella plugin] Internal Server Error when calling a function from the API (3 posts)

  1. staffan.estberg
    Member
    Posted 1 year ago #

    I'm running a local WP install under http://localhost/mypage with Stella v 1.3.47, and I can't get my head around how to call the functions from the API - whenever I try and make a call I get an Internal Server Error. Read that the plugin might not work when the base path is a subfolder so I created a Vhost placing it directly under http://mypage, still with the same result.

    Running this inside functions.php -

    add_action( 'stella_init', 'stella_functions', 1 );
    
    function stella_functions() {
       $current_lang = stella_get_current_lang();
       $langs = stella_get_lang_list();
    }

    and this inside index.php (only using this as page file for the entire site, it's a "one page" solution):
    stella_get_current_lang();

    http://wordpress.org/extend/plugins/stella-free/

    Edit: I don't get an Internal Server Error anymore, but I still don't get any data when calling a function from the API.

  2. Ruslan.Khakimov
    Member
    Plugin Author

    Posted 1 year ago #

    Please, try this one:

    add_action('after_setup_theme', 'stella_functions', 1000);
    
    function stella_functions() {
    	$current_lang = stella_get_current_lang();
    	$langs = stella_get_lang_list();
    }
  3. staffan.estberg
    Member
    Posted 1 year ago #

    Thanks, still doesn't show anything though. Just to make sure, calling the functions outisde of the loop works? Such as before the <html> element -

    <?php
    stella_get_current_lang();
    ?>
    <html>
    <body>
    </body>
    </html>

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.