WordPress.org

Ready to get started?Download WordPress

Forums

Plugin: Static front page (71 posts)

  1. Denis de Bernardy
    Member
    Posted 9 years ago #

    This is the official support thread for the static front page plugin:

    http://www.semiologic.com/projects/static-front/

  2. AndreasV
    Member
    Posted 9 years ago #

    Oh, once I get to build that new site of mine, I will have a lot of fun exploring your plugins. I better bookmark this page right now, because I will probably need it... =)

  3. Denis de Bernardy
    Member
    Posted 9 years ago #

    Héhé... be sure to get the latest version of the theme, too: it currently features no less than four undocumented plugins. :)

  4. Murry
    Member
    Posted 9 years ago #

    Hi there,
    Was recommended to ask here or i would not have bothered you "at home".

    Im very new to WP, using default Kubrick theme(2col) 1.5 and also a 3colversion.
    I cant use htaccess (host issue - it is apache tho) so I use the non-htaccess method of permalinks as per codex.
    Im using your "Static Page Plugin" to make a "home" page my opening page. This works well. BUT.
    The problem is that when I open WP, the Page List - ie all my static pages are not populated. But when I go open any link or category - the page list is populated then for the rest of the site usage - so the first opening doesnt show my page list.
    Not sure what the problem is - It could be the htaccess issue or something Ive left out.
    My site is VERY "test" - not public - and Im still at the hair pulling and fiddling stage - but its here :
    http://www.im-travel.net/wordpress/
    Any ideas gratefully received, thanks.

  5. Denis de Bernardy
    Member
    Posted 9 years ago #

    does the problem occur when you activate the plugin too?

  6. Kafkaesqui

    Posted 9 years ago #

    Denis, the issue was discussed a bit here:

    http://wordpress.org/support/topic/33493

  7. imbng
    Member
    Posted 9 years ago #

    I was having the same problem so I deactivated the plugin and removed the php file. I still had the problem so I reinstalled (only the php files) WP and it seemed to take care of the issue.

  8. Denis de Bernardy
    Member
    Posted 9 years ago #

    ok. so it would be wp, then

  9. Murry
    Member
    Posted 9 years ago #

    Hi Denis,
    Sorry about delay in getting back - dog sitting.
    I havent tried to deactivate the plugin.
    I dont quite follow what imbng suggests. Can you Denis suggest what to test to exclude WP or any other issue - I dont know here - this is all too new for me to fully understand the technics. Thanks

  10. Denis de Bernardy
    Member
    Posted 9 years ago #

    simply deactivate the plugin, and see if the page list displays properly. if the list doesn't show properly, then it's very obviously wordpress-related. possibly a config error. or a straightforward bug.

  11. Murry
    Member
    Posted 9 years ago #

    OKayyyy :)
    So I uninstalled the Plugin - and the pages display on loadup.
    In that case it appears plugin related. Do tyou have a suggestion?
    I can follow php but not program.
    The other option if its someconflict is to try the other method of static pages suggested in Codex.
    Or is this a possible result of using index.php for permalinks?
    TAI

  12. Denis de Bernardy
    Member
    Posted 9 years ago #

    i noticed you were running 1.5 rather than 1.5.1. could do the trick. there were known issues with permalink-related stuff in 1.5 interacting with the plugin

  13. Murry
    Member
    Posted 9 years ago #

    OK, I will try to do an upgrade (tomorrow) Im absolutly flat just now.
    I will get back to you hopefully with good news. Thanks

  14. Murry
    Member
    Posted 9 years ago #

    Hi Denis,
    Good news -- the upgrade to 1.5.1 from 1.5 now shows the home page on load AND loads all the pages in the Pages folder.
    Whatever it was - is something in 1.5.
    Sorry I had to stop last night - it was like nearly 1am and we had been working all day - worth the wait. Thanks for help.

  15. juliano
    Member
    Posted 9 years ago #

    The static-front-page is neatly solving a problem I was having with my blog. However, I have found a quirk with its use. I am still investigating, but I am approaching the my limits of understanding of the WordPress code, so I thought I would post my findings so far.

    My theme displays pages slightly differently to posts. It uses the is_page() function to determine whether to include some of the features like categories and archives. [There is another way I could have done this which I note in Solution 3, below.]

    The is_page function wrongly returns false when visiting the static home page using the root URL. It correctly returns true when visiting the same page using the /home URL. I found that the is_page function returns a cached result calculated by the parse_query function, which in turn actually parses the URL to tell whether it is a page or not. The sem_static_home_link() function fools this parsing code, and thus is_page function returns the wrong value.

    I suspect that there are two or maybe three possible solutions.

    Solution 1, fix it in the plug-in: Adding another filter to just the right spot may allow the plug-in to wait until after parse_query has run, and then overwrite the cached value used by is_page. Finding that right spot is still a little beyond me - I suspect the option_home filter might be significant, but I am not at all sure.

    Solution 2, work around it: Have a separate template for the home page from the other pages/posts, and let it ignore the value of is_page - it should just assume it is a page.

    Solution 3, an unlikely, but possible workaround: Rather than having a single template for pages and posts, separate them into two templates. This will only work, if WordPress doesn't use the exact same is_page function to determine which of the two templates to use. I suspect this solution won't work.

    I hope this is clear!

  16. Denis de Bernardy
    Member
    Posted 9 years ago #

    "The is_page function wrongly returns false when visiting the static home page using the root URL."

    Nope. The is_page function rightly returns false when visiting the static home page using the root URL. Use is_home instead. :)

    With the plugin enabled, the permalink to yourblog.com/?p=[home_page_id] will return yourblog.com/ instead. So you'll be testing is_home() rather than is_page().

  17. juliano
    Member
    Posted 9 years ago #

    Thanks for responding so quickly!

    I have avoided simply using is_home because I am re-using my same theme across two blogs (and I expect it to grow to more later). One uses the static front page, and the other doesn't, so assuming that "is_home() implies is_page()" is not safe.

    I have worked around the problem by using the second proposal above. I have created a home.php in my template. It checks the value of "isset($sem_sp_page_id)" and uses that to decide whether to include my index.php or page.php template.

    I am not convinced that it is correct for is_page to return false, but given this workaround is working for me, I am satisfied. If there is a lot of demand to fix is_page from others, you might like to consider looking at it. If I am the only person with this issue, please consider it Case Closed, and accept my thanks for a very useful plug-in.

  18. dherren
    Member
    Posted 9 years ago #

    Just noticed something odd as part of a WP1.5.1.2 and StaticFrontpage 1.3 upgrade. I haven't been able to determine where the problem lies yet, but here goes...

    Since the change, clicking on the comments link on the front page does nothing, whereas before the page would update to include the comments form. This happens even using the default theme that ships with 1.5.1.2 (as well as with my custom theme)

    The home page (page id =1) of the site is:

    http://www.fhuhs.org/

    The link being generated for Comments on the pushed front page is:

    http://www.fhuhs.org/#comments

    but should, I believe, be:

    http://www.fhuhs.org/index.php?page_id=1

    When manually entered as above, the comments form draws correctly.

  19. Denis de Bernardy
    Member
    Posted 9 years ago #

    @David:

    Actually, it's a feature. the plugin used to miss a couple of permalinks that directed to the 'page', as in index.php?page_id=1

    To fix, either:

    - manually add the comments in your home.php template;
    to do this, insert:
    '$withcomments = true;'
    before:
    'comments_template();'
    - or... comment the following line in the plugin:
    add_filter('page_link', 'sem_static_home_link', 10, 2 );

  20. dherren
    Member
    Posted 9 years ago #

    > - or... comment the following line in the plugin:
    > add_filter('page_link', 'sem_static_home_link', 10, 2 );

    That did the trick. Many thanks!

  21. cool_fritz
    Member
    Posted 9 years ago #

    Great plugin, thanks. If anyone is having trouble coming up with a solution for a "blog" page with this plugin see this thread. This solution is based on using one category (with sub-categories if needed) just as the plugin author suggested. Sorry if this is obvious to all you PHP gurus but I know there are probably other WP/PHP newbies such as myself who may find it useful.

  22. makwak
    Member
    Posted 8 years ago #

    I have a small problem with Static Front Page plugin and the Per-Post Styles plugin...
    http://www.blindmuse.com/blog/2004/05/27/per-post-styles/
    My static front page has a different style from the rest of the blog, as using the perpoststyles plugin. So, when I go:
    http://.....blog/home/
    I get the correct style
    when I go to
    http://.....blog/
    I get the style of the rest of the blog, even tho I get the correct static page...

  23. Denis de Bernardy
    Member
    Posted 8 years ago #

    make a home.php template, and call the correct style from it.

  24. makwak
    Member
    Posted 8 years ago #

    Yes this is exactly what I did next. I made a homepage.php template, with a new style called post2, which I added to the style.css and made the static front page from homepage.php.

    Exactly the same problem has occurred. If I go to:
    http://www.computerfinearts.com/collection/walczak/futureface/home
    then the layout is fine
    If I go:
    http://www.computerfinearts.com/collection/walczak/futureface/
    the content is correct, but it appears to default to the 'normal' layout for the rest of the site.

    Any ideas?

  25. Denis de Bernardy
    Member
    Posted 8 years ago #

    I believe you have it wrong. my plugin makes the page use the home.php template when one exists. the other plugin you are using will have an effect on the page.php template.

  26. makwak
    Member
    Posted 8 years ago #

    yes you are right, I was wrong. I was so intent on using the csstyle changing plugin I hadnt read about page.php

    sorry to trouble.

  27. DaveReed
    Member
    Posted 8 years ago #

    Hi, the plugin does exactly what I need, but on the page in question I'm getting the "Filed Under" category name and date inserted as if it was a regular blog post. This doesn't happen with the plugin off. Do I need to change some code somewhere?

    thanks.

  28. Denis de Bernardy
    Member
    Posted 8 years ago #

    home.php

  29. twotwentysix
    Member
    Posted 8 years ago #

    I was wondering how it is possible to use the mini loop with this plugin.
    I wanted to have a static frontpage with a small newsbox.
    TIA

  30. WisTex
    Member
    Posted 8 years ago #

    I found a simply way to solve the problem of the static home page using the post template instead of the page template. If you like the formatting used on the pages, then copy page.php and save it as home.php in your active template folder. Your home page will now look like a page instead of a post.

Topic Closed

This topic has been closed to new replies.

About this Topic