WordPress.org

Ready to get started?Download WordPress

Forums

StatComm (StatPress Community) Multisite Edition
[resolved] [Plugin: StatComm (StatPress Community)] Forgets collected data of the last days (20 posts)

  1. barfuss joko
    Member
    Posted 2 years ago #

    Mh, now this happend the second or third time. StatComm forgot the collected data of yesterday and the day before yesterday. This happend the second or third time.

    Last time this happend, I had the impression that it remembered this forgotten data a few days later and added it to that day.

    I also collect data with the jetpack plugin and the comparision of both statistics show this impression, too.

    Maybe you can validate my impression by me letting you have a look into my blog statistics, using Skype or something like that.

    http://wordpress.org/extend/plugins/statpress-community-formerly-statcomm/

  2. barfuss joko
    Member
    Posted 2 years ago #

    I'm sorry for my bad english, I'm a german user...

  3. barfuss joko
    Member
    Posted 2 years ago #

    That's weird. Just seen, the data is there, now. Don't know the issue. I only turned on and off again the feature "Display error counter in graphic view(in red)".

  4. WPReady
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for your comments.
    We'll check if there is an issue related with the counters.

  5. barfuss joko
    Member
    Posted 2 years ago #

    Mh, the problem occured again, only a few minutes after 12pm. I took a few screenshots to prrof the problem.
    There you can see the other problem (visitor count this month), I posted a few weeks ago.

  6. eduardo.jauch
    Member
    Posted 2 years ago #

    I have this same problem. In the StatComm page, the Overview is showing wrong info. One of the days (the bars) show 0 to everything but the spiders, but I had many hits that day, unique visitors, and so on, that on the day itself it was showing.
    Strangely, in the Details page, the unique visitors, for example, show the correct number for that specific date.
    Also, in the overview, the "This Month" and "Yesterday" Columns also show different numbers than the "Details page" for the unique visitors...

    I have the "jetpack" installed, with the statistics. This could cause any kind of trouble with StatComm?

  7. WPReady
    Member
    Plugin Author

    Posted 2 years ago #

    Thank for your comments. It is unlikely Jetpack cause any problem, but we will research any potential conflict before pronounce a final judgment.

    Currently Statcomm is using a cache system to improve the performance. This cache records any results excluding today numbers. If the cache has is not synchronized with the current time, an inaccuracy would happen.

    We'll dig into this problem, thanks for pointing it out.

  8. WPReady
    Member
    Plugin Author

    Posted 2 years ago #

    Hello everyone. Today we upgraded Statcomm to 1.7.20.
    This version is addressing many aspects but this problem in particular is still in analysis.

    We hope we'll have a solution soon.
    Thanks and enjoy the day.

  9. WPReady
    Member
    Plugin Author

    Posted 2 years ago #

    By the way, we want to clear out few things. Statcomm does not miss counts nor forgets saving incoming traffic. The problem probably resides in the cache system and the way it sees the current day. We are working to improve this area.

    There is a workaround to solve the problem. Every time the options are saved, the cache is discarded and rebuilt along the time. Recalculations are made again and hopefully, corrected. Just save current option, you don't need to make any changes and the data will be adjusted.

    Our apologies for the problem.

  10. barfuss joko
    Member
    Posted 2 years ago #

    The problem still occures with the new version (1.7.31).
    I tried not so save any setting over the day and just had a look to the statistics (1:30 am), 0 visitors, 0 pageviews, 0 spiders, 0 feeds.
    Yesterday (round about 11:30 pm) a/b/c/d.
    I saved the settings and now (1:35 am) I have a + eps1 / b + eps2 / c + eps3 / d + eps4 ...

  11. WPReady
    Member
    Plugin Author

    Posted 2 years ago #

    Ok, we think we know what's going on. We're going to check our idea and get back to you.

    Thanks for your comments.

  12. WPReady
    Member
    Plugin Author

    Posted 1 year ago #

    We finally found the problem. We are making few more tests before launching 1.7.40.

    Thanks for your help in this matter.

  13. barfuss joko
    Member
    Posted 1 year ago #

    Hey guys,

    I've updated to 1.7.40 a few days ago and it seems to be fixed. I will watch to the data a few more days, before marking this topic as resolved.

  14. eduardo.jauch
    Member
    Posted 1 year ago #

    I confirm that everything seens to be ok, now.

  15. WPReady
    Member
    Plugin Author

    Posted 1 year ago #

    Glad to hear :)
    Thanks all for your feedback!

  16. barfuss joko
    Member
    Posted 1 year ago #

    IT WORKS!

    Thanks alot!

  17. lekko
    Member
    Posted 1 year ago #

    when I use the plugin statComm shows that many red (error) and the last hits indicate yellow color with 404 pages. Why is this happening, please help
    you can check here

  18. lekko
    Member
    Posted 1 year ago #

    when I use the plugin statComm shows that many red (error) and the last hits indicate yellow color with 404 pages. Why is this happening, please help

    you can check here

  19. WPReady
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Lekko,
    I follow the link but I only see your site.404 means user trying to reach pages that simply don't exists, causes for many reasons, like bad typing or incorrect links.

    Let me know how can I help you. Thanks.

  20. lekko
    Member
    Posted 1 year ago #

    why this happens when I do not have any errors, on my other websites this plugin look good

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.