WordPress.org

Ready to get started?Download WordPress

Forums

Spots
[resolved] modifications to template don't take effect (9 posts)

  1. Paul de Wouters
    Human Made
    Posted 2 years ago #

    If I modify the spot template, the changes don't reflect on the front end.
    how is that possible?
    I cleared the browser cache

    http://wordpress.org/extend/plugins/spots/

  2. Paul de Wouters
    Human Made
    Posted 2 years ago #

    I found out that if I go to the Spot post edit screen and click update, then it will detect the template change.

  3. sanchothefat
    Member
    Plugin Author

    Posted 2 years ago #

    Currently the cache is only updated when the spot is saved or edited. We're looking into taking a hash of the file contents and using to check whether the cache should be updated too but at the moment it has no way of knowing if you've edited a template.

  4. Paul de Wouters
    Human Made
    Posted 2 years ago #

    ok, I guess I just expected it to work like a regular post template.
    thanks!

  5. AndyiBM
    Member
    Posted 2 years ago #

    Great - it's not just me then :) I've been trying to make a template update but with no effect either. Just made the 'update' connection before finding this thread.

    Other than that, it's a great plugin - gives me some useful options for when setting up a site for a client.

  6. cehwitham
    Member
    Posted 2 years ago #

    I've also been using the "Update" spot for template changes to take effect.

    I've now got a site where I've got about 20 spots all using the same template and I need to update the template.

    Is there a way to kill the whole cache and have it regenerate to save me going through and updating all of the spots?

  7. sanchothefat
    Member
    Plugin Author

    Posted 2 years ago #

    Hi guys, you can kill the spots cache altogether while you're developing by defining the cache timeout.

    Place this code in your functions.php:

    define( 'SPOTS_CACHE_TIME', 0 );

    I'll add this note to the readme too. If you develop in debug mode (which is generally a good idea) add this instead:

    if ( WP_DEBUG )
        define( 'SPOTS_CACHE_TIME', 0 );

    ---
    Really sorry it's taken so long to respond, we're a small team so support for free plugins can't always be a priority when we have lots of client work which is pretty much all the time.

  8. cehwitham
    Member
    Posted 2 years ago #

    Many thanks Rob, that's very helpful.

    Totally understand the small team situation and really appreciate you guys taking time to release things back into the community and provide support as much as you can.

  9. sanchothefat
    Member
    Plugin Author

    Posted 2 years ago #

    No problem, I appreciate your patience. See you at WordCamp!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags