WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Spell Checker] Fatal Error on Install (5 posts)

  1. jjdarragh
    Member
    Posted 5 years ago #

    I am getting a fatal error when I try to activate the spell checker plug-in. It says:

    Warning: No such file or directory in ...wp-content/plugins/spell-checker/spell-plugin.php on line 36

    and there most certainly is the needed file in the directory. Please advise.

    Thanks!

  2. Glasgowvant
    Member
    Posted 5 years ago #

    Did you ever get answer to this problem?

    I'm having the same problem.

    I'm only trying to install this plugin because the built in spell check does not work for some reason on one of my blogs. Can anyone tell me if this is related.

    Thanks

  3. cpein
    Member
    Posted 5 years ago #

    Me too, same problem, can't find answer!

  4. dv8tminds
    Member
    Posted 5 years ago #

    Disclaimer. I don't know step one about writing php code, infact can just about spell .php 3 out of 4 times correctly with references, so edit at your own risk. LOL

    I am using WP 2.7.1, mostly the default setting, and default directory structure.

    Error # 1

    Warning: require(/******/blog/wp-content/spell-plugin/spellInclude.php)

    [function.require]: failed to open stream: No such file or directory in

    **********/blog/wp-content/plugins/spell-plugin.php on line 36
    ------
    spellInclude.php is not in the /wp-content/spell-plugin subdirectory, it is in the wp-content/plugins/spell-checker subdirectory. In note pad I just used find and replace to replace spell-plugin with plugins/spell-checker.

    Takes us to error # 2

    Warning: require_once (/******/blog/wp-content/wp-config.php) [function.require-once]: failed to open stream: No such file or directory in *******/blog/wp-content/plugins/spell-checker/spellInclude.php on line 7

    -------
    wp-config.php is not in /blog/wp-content, it is in /blog. In the spellInclude.php file I changed

    require_once (dirname(dirname(__FILE__)) . "wp-config.php");

    To read

    require_once (dirname(dirname(dirname(__FILE__))) . "wp-config.php");

    After these changes I was able to get the Spell Checker widget to activate. I have made the changes I want to the Spell Check config page in my Admin Dashboard, and I see the spell check icon when I post a new comment. What I can't figure out, from the Install instructions on the WP plugin page, is how do I get the spell checker to work for comments?

    Hope someone can HELP!!!!MJI

  5. SexyDawnT
    Member
    Posted 4 years ago #

    Still not working. How did this thing get such a high star rating?

Topic Closed

This topic has been closed to new replies.

About this Topic