WordPress.org

Ready to get started?Download WordPress

Forums

Spectacu.la Discussion
[resolved] Comment box border missing in IE and other bugs (4 posts)

  1. jonmrich
    Member
    Posted 4 years ago #

    Biggest problem since upgrading to Spectacula 2.0 is that in IE (I'm using 8) the border for the comment boxes (author, email, website, comment) are all missing. They are also missing in Firefox. They are there in Chrome.

    http://www.doseofdigital.com/2010/07/7-links-dose-of-digital/

    Any idea how to fix this?

    Also, IE doesn't appear to be showing the new style of "reply" with the button instead of the text link that was in the previous version. That is, the old style still appears to be there.

    Also, (in all browsers) when I'm logged in and try to add a comment, the gravatar that appears next to the comment box is the one from the comment immediately before the box and not my own. Once the comment posts, the right gravatar is there. Could be a little confusing to people.

    Thanks,
    JMR

    http://wordpress.org/extend/plugins/spectacula-threaded-comments/

  2. jonmrich
    Member
    Posted 4 years ago #

    Extremely odd, but all seems to be working now. I didn't change anything to any codes or settings though.

    The only thing I did was to log in (as admin) in each browser and then log out. After this, the styles were fine.

    The bug with the gravatar still exists though.

    One more odd thing...the label above the comment form, which used to be something like "Leave a Comment" is now missing and I can't figure out where to put it back in.

    Thanks,
    JMR

  3. Spectacula
    Member
    Plugin Author

    Posted 4 years ago #

    Sounds like your style issues were associated with cached CSS. I thought I'd done enough to force a flush of the cache, obviously not.

    The gravatar bug is a little odd, I'll take a look at that. It didn't come up in my own local testing so when I find the cause I'll get a 2.0.1 out.

    I chose to remove the "Leave a comment" title as it seemed mostly superfluous. If you want to add it back in you'll find a file called functions.php in the plug-in's folder under includes and in there you'll find a function called spec_comments_form, you'll likely want to add it around line 160. However, if you're willing to wait for the next version I'll add another option to the options page that'll let you define a title for the top of that box.

  4. Spectacula
    Member
    Plugin Author

    Posted 4 years ago #

    I've updated this plug-in to 2.0.1.
    You'll now have the option of setting a title for the form from the 'spectacu.la discussion' settings page and also the option of turning off the comment form avatar.

    I couldn't recreate the avatar issue you have but I suspect it's down to a plug-in as your avatars are different sizes to the sizes I request within the comment loop. That's not a problem as I built this to respect whatever avatar sizes turn up, it would seem that something in there is not being reset correctly so we're left with the avatar from the last user. So to get around this just turn off the comment avatar with the new option.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic