WordPress.org

Ready to get started?Download WordPress

Forums

Spam Free WordPress
[resolved] Too buggy (5 posts)

  1. pubwvj
    Member
    Posted 1 year ago #

    There have been so many updates and so many bugs that I am seriously questioning if this plugin is being tested prior to each release. I've deactivated it once again.

    http://wordpress.org/extend/plugins/spam-free-wordpress/

  2. Todd Lahman
    Member
    Plugin Author

    Posted 1 year ago #

    With the introduction of 1.7, and a complete rewrite of the security for the comment form, I discovered there are a ton of poorly written themes, and a few problematic plugins, that required updates to work around. The frequency, as I explained already on the official support page, was to insure fixes for the problems reported to me, and would resolve issues for people right awway as they were fixed. This is why your issue with the plugin was fixed, and why you started using it again. I checked your site to insure the plugin was working since you commented it wasn't previouly. This is how I know that it still works for you, and that you only voted the plugin is broken, and left this comment here, minutes after the 1.7.8.1 update was released, ONLY because you don't like the frequent updates, and not because it isn't working for you.

    The better option for you is to not update until the frequent updates stop for a week or so. The updates are important to a lot of people, which included you at one point in the update cycle.

    The only bugs came from poorly written themes, and the W3 Total Cache plugin, which I managed to write work around code for. The plugin itself is always tested on my test server, and my own commercial production blogs, before release so I KNOW it works properly when a properly written theme, and plugins are installed.

    If you don't like the unpaid time I put into making sure this plugin works for people who use it, then don't use this free plugin.

  3. pubwvj
    Member
    Posted 1 year ago #

    Actually, no, it has not been working for me before the flurry of updates. My theme is an official WP theme so calling it "poorly written" is a poor excuse. A new bug in SFWP is that when I write a new post and do Preview SFWP causes an error.

    I'm glad you're fixing bugs but what I would really like is to go back to what seemed to be a working version that I was originally using. For now I'll wait and hope you can work out the bugs in a few weeks.

  4. Todd Lahman
    Member
    Plugin Author

    Posted 1 year ago #

    I can see your theme is based on Twenty Ten, but I don't know if you've modified it for your own use or not.

    Poorly written themes load old JavaScript libraries, and poorly written plugins cause JavaScript to load improperly or not to load at all. Those may not be your issues.

    Spam Free WordPress only impacts your comment form, not the preview of a post. I ran two tests myself. First I created a new post, but did not save it, and tried using the "Preview" button. As expected the post could not be found, because it doesn't exist yet until I save it. So that was normal. Second I opened an existing post in the edit screen, and clicked "Preview Changes," which opened the post page as expected because it exists.

    Unless you are doing something different than I am then I would conclude you don't have an issue at all, or at least it isn't related to my plugin. You would only have a problem with my plugin if you were unable to leave a comment with the plugin activated. Are you having trouble leaving comments?

    If I am not seeing what you are trying to describe, then please provide step by step detail so I can recreate your issue.

    Since I released the 1.7 version the problems that have been reported were either caused by another plugin, or a poorly written theme, and so far I've been able to help everyone solve their issue. If you'd like help resolving your issue then we will have to do it on the official support page at http://www.toddlahman.com/spam-free-wordpress/ because my time for support is limited, and as I say everywhere on the plugin page on WordPress.org, I don't provide support in this forum.

    I am closing this as resolved for this thread, since we will resume on the official support page.

  5. pubwvj
    Member
    Posted 1 year ago #

    The preview problem happened after I reactivated SFWP. It only happened once, so far, so I don't know what is going on there.

    I turned off and then deleted SFWP using the WP admin panel.

    Today, being that it is a new week and I'm ever optimistic, I tried reinstalling SFWP 1.7.8.2 using the WP admin panel. When I try to leave a test comment (not logged in as myself) I get a message:

    Spam Free WordPress rejected your comment because you did not enter the correct password or it was empty.

    I've tried that with Invisible Password, Click Field and Button as well as with AutoGenCommentField on and off. I get the same every time. When I click the field in that mode nothing happens. I have Javascript turned on in my browser (uptodate Safari).

    The result is if I have SFWP enabled then readers can't leave comments on my blog. That does stop spam 100% but the side effects are killing the patient.

    My theme is standard, that is not the issue.
    The old SFWP didn't have any problem with the other plugins I use and I haven't added new ones.

    The old version of SFWP worked. Is there any way to go back to that?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags