WordPress.org

Ready to get started?Download WordPress

Forums

Spam Free WordPress
[resolved] comments.php problem (5 posts)

  1. riversway
    Member
    Posted 2 years ago #

    This is about getting the password field to appear. I read the other posts and still can't get the box to appear.
    I am using the Connections Reloaded theme and the comments.php file doesn't have a <form> opening tag it does have a </form> tag however. I tried adding the line of code for earlier versions,<?php if(function_exists (’tl_spam_free_wordpress_comments_form’)) { tl_spam_free_wordpress_comments_form(); } ?> after the url field, but still cannot get a password field to appear on the form. I have disabled all caching. I am more than willing to email you code, etc if that will help.
    The site is http://www.riverswaycommunity.org hosted by dreamhost.

    Thank you for your response.

    Gil

    http://wordpress.org/extend/plugins/spam-free-wordpress/

  2. riversway
    Member
    Posted 2 years ago #

    PS: I am a hardware/networking guy and am still learning this side of things.

  3. Todd Lahman
    Member
    Plugin Author

    Posted 2 years ago #

    The line of code you have looks correct, except it has smart single quotes instead of the normal single quote that is otherwise known as an apostrophe. The smart quotes don't work in PHP. The code in comments.php should look like the lines below.

    <p><label for="url"><?php _e('Website'); ?></label><input type="text" name="url" id="url" value="<?php echo $comment_author_url; ?>" size="22" /></p>
    
    <?php if(function_exists ('tl_spam_free_wordpress_comments_form')) { tl_spam_free_wordpress_comments_form(); } ?>

    Note that tl_spam_free_wordpress_comments_form is surrounded by the correct single quote ' rather than the single smart quote ’ that you were using.

  4. riversway
    Member
    Posted 2 years ago #

    Thanks Todd, just to let you know, that was a direct copy and paste from your website.

    I greatly appreciate your quick response. It works great now.

    Gil

  5. Todd Lahman
    Member
    Plugin Author

    Posted 2 years ago #

    Thank you for letting me know where you got that line of code. I've corrected my error on my blog.

    Glad to see all is working Gil.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic