WordPress.org

Ready to get started?Download WordPress

Forums

Spam Free WordPress
[resolved] No password field (6 posts)

  1. theresavs
    Member
    Posted 2 years ago #

    I've tried everything to get the password field to show up. I've disabled all the other plugins and it still doesn't show. The website is http://www.paulaohara.com/
    Here's the comment.php code for the theme: http://pastebin.com/q6mQv7g7

    Can you help me figure it out? I've also tried some of the pastebin codes you've posted but none of them work either.

    http://wordpress.org/extend/plugins/spam-free-wordpress/

  2. Todd Lahman
    Member
    Plugin Author

    Posted 2 years ago #

    Your comments.php code looks correct.

    Make sure to activate Spam Free WordPress, and deactivate Ajaxed WordPress.

    Ajaxed WordPress is old, was last updated in 2009, and is no longer available for download since it was removed from the WordPress repository, and the author has not made it available elsewhere. The Ajaxed WordPress web site says it conflicts with plugins that interact with the comment form as Spam Free WordPress does.

  3. theresavs
    Member
    Posted 2 years ago #

    I just did that and the password field still doesn't show up. Like I said, I've deactivated all the other plugins before and it still didn't work.

  4. Todd Lahman
    Member
    Plugin Author

    Posted 2 years ago #

    Spam Free WordPress is a simple plugin that inserts an HTML password form field into the comment form, and then uses PHP on the backend to authenticate the password with the one in the database for each post, so it should work without any conflicts with any other plugins.

    I do see a lot of issues with this blog that should be looked into. For example, there are a lot of plugins running that could be causing a lot of conflicting problems making it difficult to troubleshoot a simple issue like a password field not showing up.

    WordPress 3.3.1 runs jQuery 1.7.1 by default, but the blog is also loading jQuery 1.6.2 before it loads 1.7.1, and it loads both at the same time.

    <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>
    <script type='text/javascript' src='http://www.paulaohara.com/blog/wp-includes/js/jquery/jquery.js?ver=1.7.1'></script>

    It appears jQuery 1.7.1 is loading with the Nextgen Gallery plugin.

    The blog Theme is also loading its own jQuery 1.2.6, which makes 3 versions of jQuery running on the same page at the same time.

    <script type="text/javascript" src="http://www.paulaohara.com/blog/wp-content/themes/PaulaO/js/jquery.js"></script>

    jQuery 1.7.1 comes with WordPress 3.3.1, and should be the only version running.

    There is also the WP Spamfree plugin running, which could also cause problems.

    It appears there may be many issues with this blog that need to be sorted out. A good place to start is to make sure only one version of jQuery is loading, disable all other plugins except Spam Free WordPress, and see if the password field appears as it should.

    The only suggestion other than not using other comment spam plugins with Spam Free WordPress, and fixing any other issues that existed before Spam Free WordPress was used, would be to also try this comments.php code:

    http://pastebin.com/a35F978M

  5. theresavs
    Member
    Posted 2 years ago #

    Thanks for catching the extra jquery calls. I removed the extra ones in the head section, but even after deactivating all the plugins, the password field still doesn't show up. I'm just going to give up for now. Thanks for your help.

  6. Todd Lahman
    Member
    Plugin Author

    Posted 2 years ago #

    Wish I could have been more help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic