WordPress.org

Ready to get started?Download WordPress

Forums

Spam Captcha
New version gives fatal error during activation (21 posts)

  1. rodtrent
    Member
    Posted 2 years ago #

    Fatal error: Class 'pluginSedLex' not found in D:\myitforum\myitforum\wwwroot\myitforumwp\wp-content\plugins\spam-captcha\spam-captcha.php on line 22

    http://wordpress.org/extend/plugins/spam-captcha/

  2. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    It seems that it is a random bug of WordPress installer

    Please retry the activation to be sure or reinstall the plugin with the same version

    Should work

    Tell me if it does

  3. rodtrent
    Member
    Posted 2 years ago #

    Same error...

    Fatal error: Class 'pluginSedLex' not found in D:\myitforum\myitforum\wwwroot\myitforumwp\wp-content\plugins\spam-captcha\spam-captcha.php on line 22

  4. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    What did you do ? Full reinstall or just a simple reactivation ?

  5. rodtrent
    Member
    Posted 2 years ago #

    Just reactivation. I'll try a full install next.

  6. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    Yes... It is better if it is done by FTP rather than the embedded wordpress features

  7. rodtrent
    Member
    Posted 2 years ago #

    Nope...totally uninstalled, reinstalled, and activation error is the same.

  8. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    Can you confirm me that there is a core.class.php file in this plugin folder a that this file contains a pluginSedlex class ?

  9. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

  10. rodtrent
    Member
    Posted 2 years ago #

    It does seem to exist. I even copied your example straight into the core.class.php file and tried again to no avail. Taking your previous suggestion about a general WordPress installation routine problem, I even tested a couple other plugins. Spam Captcha is the only one with issue.

  11. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    The example is from the WordPress Svn repository
    Have you reinstall the plugin by downloading the zip on WordPress and copy its content into the plugins folder by FTP ???

    Thanks for your assistance

  12. rodtrent
    Member
    Posted 2 years ago #

    Yes...did that, too.

  13. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    And In that zip, the core.class.php does exists ???

  14. rodtrent
    Member
    Posted 2 years ago #

    Yes...here's the contents from the Zip file...

    [1197 lines of code moderated as per the Forum Rules. Please use the pastebin]

  15. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    If you do so and there are still an issue, I have no idea !
    That should work as there is, as you see, the needed class

  16. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    I have updated the plugin

    Does it change anything ?

  17. rodtrent
    Member
    Posted 2 years ago #

    Just tried it...same issue.

  18. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    Definitely I do not understand ... Do you have another plugin of mine ?
    What are the plugins installed ?
    What is your version of wordpress ?
    May you try another plugin of mine such as http://wordpress.org/extend/plugins/image-zoom/

    Thanks ?

  19. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    Is it a multi-site worpress installation ?

    May you try to contact me by email ? My email is in the header of the spam-captcha.php file

  20. Sed Lex
    Member
    Plugin Author

    Posted 2 years ago #

    I will send you debug files

  21. rodtrent
    Member
    Posted 2 years ago #

    Not a multi-site installation (i.e., the flag has not been set). WordPress 3.2.1. We do have a bunch of plug-ins installed, including a few BP plug-ins.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic