WordPress.org

Ready to get started?Download WordPress

Forums

SoundCloud Shortcode
[resolved] problem with v2.2.5 (17 posts)

  1. martin
    Member
    Posted 2 years ago #

    Hello,

    until today I was using version 2.2.1 (I believe) on my 'live' websites and everything worked fine. Today I updated the plugin to v 2.2.5 and now only the link (http://api.soundcloud.com/tracks/...) is being displayed but not the player itself. I use one wordpress installation that is v 3.4.1 and one that is a little bit older. On both installations v 2.2.5 is behaving as described above.

    On my localhost installation the v 2.2.5 is working with an older wordpress installation.

    Besides, thanks for making the app, I truly appreciate it.

    Martin

    http://wordpress.org/extend/plugins/soundcloud-shortcode/

  2. por_
    Member
    Plugin Author

    Posted 2 years ago #

    Could you please post the code you are using and also list any custom plugin settings you might have set?

  3. martin
    Member
    Posted 2 years ago #

    hi,

    sorry, what code do you mean? If you mean the code that I insert into the post, it is the one tagged for wordpress :
    [soundcloud url="http://api.soundcloud.com/tracks/..." iframe="true" /]

    Plugin settings:
    widget type: flash (also tried it with html 5)
    player width: 100%
    auto play: default
    show comments: default
    everything else is blank

  4. The Daily Indie
    Member
    Posted 2 years ago #

    I've got exactly the same problem. I'm also using WordPress v3.4.1 and Soundcloud Shortcode v 2.2.5!

  5. por_
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm, the code got cut off there. You can put it in between ` characters, so that doesn’t happen. But I assume you had something like this:

    [soundcloud url="http://api.soundcloud.com/tracks/54330791" width="100%" height="200" iframe="true" /]

    I tried it with the same settings and I can’t reproduce. Does updating the post work? It might have something to do with caching. I’d really like to see this fixed, but I have no clue what’s causing it right now.

  6. The Daily Indie
    Member
    Posted 2 years ago #

    Updating the post doesn't work for me. Is there a temporary solution, like installing an older version of Soundcloud Shortcode?

  7. por_
    Member
    Plugin Author

    Posted 2 years ago #

    Currently that’s not possible, but I’ll try to make that happen today.

  8. The Daily Indie
    Member
    Posted 2 years ago #

    That would be great, thank you!

  9. por_
    Member
    Plugin Author

    Posted 2 years ago #

    You can revert back to version 2.0 now if you want. That was the stable one from the last few months.

    http://downloads.wordpress.org/plugin/soundcloud-shortcode.2.0.zip

  10. The Daily Indie
    Member
    Posted 2 years ago #

    Thank you!

    But at the same time: sorry... But I'm almost there I guess.

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_IF, expecting T_FUNCTION in /home/vhosts/thedailyindie.nl/httpdocs/wp-content/plugins/soundcloud-shortcode/soundcloud-shortcode.php on line 49

  11. por_
    Member
    Plugin Author

    Posted 2 years ago #

  12. The Daily Indie
    Member
    Posted 2 years ago #

    The plugin is working, but it seems to have the same problem as v 2.2.5

    I'm confused :-)

  13. por_
    Member
    Plugin Author

    Posted 2 years ago #

    Me too. Any way I could log in to the blog and tinker around a bit?

  14. The Daily Indie
    Member
    Posted 2 years ago #

    That would be lovely! Could you send me your e-mail at thedailyindie@gmail.com ?

  15. martin
    Member
    Posted 2 years ago #

    hello por_
    you are welcome to check my sites. Where should I send you the information to?

  16. por_
    Member
    Plugin Author

    Posted 2 years ago #

    Hey martin, I already logged into The Daily Indie’s WordPress. His problem sounds very similar to yours. I’ve traced the problem to a specific WordPress function, but since I can’t inspect the WordPress code, I can’t debug it any further.

    The only thing I can recommend right now if you have any other plugins installed, to disable them one by one to see if one of them might be interfering with the SoundCloud plugin.

    Alternatively you can try installing any of the older versions. Version 2.0 should be stable. http://downloads.wordpress.org/plugin/soundcloud-shortcode.2.0.zip

  17. martin
    Member
    Posted 2 years ago #

    hello por_
    thanks for the quick help. I now installed the version 2.0 and it works perfectly fine. I also tried Version 2.1 but it is, as Version 2.2.5, not working correctly.

    thanx, martin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.