WordPress.org

Ready to get started?Download WordPress

Forums

SoundCloud Shortcode
[resolved] New update is broken (16 posts)

  1. MDesigner0
    Member
    Posted 1 year ago #

    This broke all the players on my site. I've updated to the new code, and one page works while the rest do not, even though they are all following the same format.

    Example:

    The source code for this page: http://samhulick.com/portfolio/me3ec (which works properly)
    [soundcloud]http://soundcloud.com/mdesigner/sets/mass-effect-3-extended-cut[/soundcloud]

    The source code for this page: http://samhulick.com/portfolio/me3 (which is broken)
    [soundcloud]http://soundcloud.com/mdesigner/sets/mass-effect-3-demo-reel[/soundcloud]

    Please explain?

  2. MDesigner0
    Member
    Posted 1 year ago #

    Does a set's "apps" setting need to be enabled in SoundCloud for this to work? What about "widgets"?

  3. MDesigner0
    Member
    Posted 1 year ago #

    Ok, one of them (the second link) started working without any code changes from me. Something is funky on SoundCloud's end, I imagine. But once I changed the code to [soundcloud height="450"], it broke again.

    I hope someone can shed some light on this. This is the HTML5 version, BTW. I've temporarily switched to Flash mode which works (though not ideal).

  4. por_
    Member
    Plugin Author

    Posted 1 year ago #

    I can’t reproduce this I’m afraid. Do you have some caching plugin running maybe? The plugin uses SoundCloud oEmbed which looks fine for that second link, so it looks like the permissions are set correctly at least. (http://soundcloud.com/oembed?url=http://soundcloud.com/mdesigner/sets/mass-effect-3-demo-reel)

    What happens when it is “broken”? Do you see an error or does it just display a link?

  5. MDesigner0
    Member
    Posted 1 year ago #

    Could you email me via my website? I'll temporarily give you an admin login and you can take a look.

  6. por_
    Member
    Plugin Author

    Posted 1 year ago #

    You should already have my email from the plugin. You can send it there.

  7. MDesigner0
    Member
    Posted 1 year ago #

    Done. Thank you!

  8. MDesigner0
    Member
    Posted 1 year ago #

    Interesting. I put up a new set, this oembed link returns a blank page.

    http://soundcloud.com/oembed?url=http://soundcloud.com/mdesigner/sets/baldurs-gate-the-black-pits

  9. MDesigner0
    Member
    Posted 1 year ago #

    Found the problem and how to fix it!

    It has to do with the widget permissions of the set or track. It MUST be set to "anybody," not "only for you." And even after setting that, you HAVE to go back to your WordPress page, and just re-update the page for some reason. Using this method I was able to fix all the music pages on my site.

    The only bummer left is that [soundcloud height="x"] is restricted to 450 max I think. I can shrink it if I need to, but I can't set it to 600, it ignores it.

  10. The Daily Indie
    Member
    Posted 1 year ago #

    I've searched for it, but where can I change the permissions from 'only for you' to anybody?

  11. por_
    Member
    Plugin Author

    Posted 1 year ago #

    @Mdesigner0: Glad you found a way to fix it. The reason why you have to update your page is because the shortcode is cached by WordPress. I can see why restricting the height of SoundCloud set players can be annoying. I can’t think of a good reason for that either.

    I could override it in the plugin, but I’d like to try and fix it properly on the backend.

    @The Daily Indie: Go to any of your sets or sounds and click the edit button. Right at the bottom you will see some permissions options.

  12. The Daily Indie
    Member
    Posted 1 year ago #

    @por_ I'm sorry, but it still isn't very clear to me. For example: http://thedailyindie.nl/new-music-o-a-animal-collective-temples-bloc-party-tamaryn/

    I only see links, so where can I find an edit button exactly?

    Thanks for your help!

  13. por_
    Member
    Plugin Author

    Posted 1 year ago #

    @The Daily Indie: I think your problem is different. This is only the case when you own the sound or set and you disallowed your sound or set to be embedded on other pages.

    I think your problem is best described by http://wordpress.org/support/topic/plugin-soundcloud-shortcode-problem-with-v225, let’s move the discussion there.

  14. MDesigner0
    Member
    Posted 1 year ago #

    Thanks Tim. So do you plan on releasing another update to allow full freedom with the height setting? Is there some temporary way I could override it?

  15. por_
    Member
    Plugin Author

    Posted 1 year ago #

    The only temporary way to override is to reset your plugin version to 2.0 at the moment. http://downloads.wordpress.org/plugin/soundcloud-shortcode.2.0.zip

    I’ll try to get it fixed on the backend though.

  16. MDesigner0
    Member
    Posted 1 year ago #

    I can wait. Thanks again for your help. PS: you may want to include a note somewhere in the plugin that says the 'widgets' permission must be enabled for everyone. That's a key thing.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.