WordPress.org

Ready to get started?Download WordPress

Forums

SoundCloud Shortcode
[resolved] Mini Player Removed? (5 posts)

  1. zechmann
    Member
    Posted 2 years ago #

    Downloaded the latest SoundCloud shortcode and now the mini player is replaced by the HTML player. Is there anyway to fix this or can I revert back to 2.1 for now??

    UPDATE: I got the mini player back by switching to Flash mode, but the height seems to be messed up (there's a lot of white space below it). Also, I'd like the html player used when I don't use the mini player.

    Thanks for any help!!

    http://silencenogood.net (the SC players on the main page should be mini)

    http://wordpress.org/extend/plugins/soundcloud-shortcode/

  2. por_
    Member
    Plugin Author

    Posted 2 years ago #

    That sounds like a regression. Can you provide the shortcode you’re using for one of the small players? If you specify iframe=false as one of the shortcode parameters, you can enable/disable the flash player on an individual basis. That way the default will still be the html player.

  3. por_
    Member
    Plugin Author

    Posted 1 year ago #

    I found a bug and pushed an update. Can you check to see if this fixes your problem?

  4. zechmann
    Member
    Posted 1 year ago #

    fixed the problem with the space below the mini player.

    Problem now is that when I switch "Widget Type" to HTML5, the mini still gets turned into the HTML5 player (with the mini's dimensions).

    Thanks for the spacing fix!!

  5. por_
    Member
    Plugin Author

    Posted 1 year ago #

    That’s expected behaviour. The default player is the HTML player now, while we’re slowly phasing out the older Flash player. Currently however, this new player does not support small dimensions yet.

    To make sure that your mini player will look good, please make sure you include the iframe="false" parameter. Example:

    [soundcloud url="http://api.soundcloud.com/tracks/53244765" params="auto_play=false&player_type=tiny&font=Arial&color=000000" width="100%" height="18" iframe="false" /]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic