WordPress.org

Ready to get started?Download WordPress

Forums

SOPA Blackout
[resolved] Turning it on right now did nothing (9 posts)

  1. Donna Fontenot
    Member
    Posted 2 years ago #

    Hm, thought I'd test it out so I'd know what it would look like, but nothing happened. I checked the box to turn it on right now and updated. Nothing changed...nada... Still see my site fine (even logged out).

    http://wordpress.org/extend/plugins/sopa-blackout/

  2. Sage Brownell
    Member
    Posted 2 years ago #

    http://wordpress.org/extend/plugins/sopa-blackout/

    On 18th January your site will display a customisable page.

    I am guessing that it will change automatically tomorrow.

  3. Donna Fontenot
    Member
    Posted 2 years ago #

    Yes, I get that, but there is an option to turn it on right now, to test it. Turning that option on didn't work.

  4. Ben Welch-bolen
    Member
    Posted 2 years ago #

    If you are looking for more options:

    http://wordpress.org/extend/plugins/sopa-blackout-plugin/

    You can tweak if you want to totally black your site out, if you want it to show a continue link that leads them to the page they were heading too, set which days you want it to show, and a lot more!

    Hope that helps!
    Thanks, Ben

  5. Donna Fontenot
    Member
    Posted 2 years ago #

    I feel like I'm speaking into a void. Never mind.

  6. Ben Welch-bolen
    Member
    Posted 2 years ago #

    I'd be happy to help you with the plugin below, the other one I don't know the author. I do have two of my sites using:

    http://wordpress.org/extend/plugins/sopa-blackout-plugin/

    And it works great!

  7. ClaytonJames
    Member
    Posted 2 years ago #

    @dazzlindonna

    "By default, logged in users will see your site's full content. If you would like logged in users to get the Stop SOPA Blackout page instead, click here"

    ...are 'ya loggin out and then checking it?

    'Cause mine is working like a million bucks in test mode.

    [edit] I'm sorry. I should have said: are you SURE you are logging out!
    My bad.

  8. eagerterrier
    Member
    Plugin Author

    Posted 2 years ago #

    @dazzlindonna - sorry for late response. It was night-time here in the UK and also the authors of plugins don't get notified of new messages here, which I still find strange.

    Anyway, onto the problem

    1. If you have WP Super Cache plugin enabled, it does work, but webkit browsers cache a copy for a very long time, so open up a different browser

    What theme are you using?

    Any caching plugins?

    What URL are you testing?

    If you would like to try and remedy it yourself, you could try finding line 314 of sopablackout.php and change the 'template_rediect' bit of the line as seen below:

    add_action('template_redirect', 'sopablackout_content');

    … to one of the following:

    muplugins_loaded
    plugins_loaded
    sanitize_comment_cookies
    setup_theme
    load_textdomain
    after_setup_theme
    auth_cookie_malformed
    set_current_user
    init
    widgets_init
    register_sidebar
    wp_register_sidebar_widget
    wp_loaded
    parse_request*
    send_headers*
    parse_query*
    pre_get_posts*
    posts_selection
    wp*

    I would start at the bottom and work upwards (please ignore the asterixes when copying and pasting.)

  9. eagerterrier
    Member
    Plugin Author

    Posted 2 years ago #

    @sage - finger's crossed (although to be on the safe side, it's good to test it)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic