WordPress.org

Ready to get started?Download WordPress

Forums

Social Web Links
[resolved] link not open new tab (10 posts)

  1. juanstecno
    Member
    Posted 1 year ago #

    Hello,
    I was installed your pluggin in http://saavedra.tk/
    It works, but link to my Facebook don't open in a new tab.
    What can I do?
    Regards.

    http://wordpress.org/extend/plugins/social-web-links/

  2. juanstecno
    Member
    Posted 1 year ago #

    Tested with Twitter link, identical situation, link not opens in a new tab. Any solution?
    Regards.

  3. juanstecno
    Member
    Posted 1 year ago #

    Hello, I was installed the last version but occurs the same. I was encountered the solution, see here (part of the code of 'social-web-links-widget.php'):
    ...
    'foreach($social_list as $entry) {
    if(trim($swl_options[$entry.'_url']) != "")
    switch($display_style) {
    case "horizontal":
    echo '<img style="vertical-align:bottom;" src="'.SWL_DIR_URL.'images/'.$icon_size.'/'.$entry.'.png"/>';
    break;
    case "one-col-noname":
    echo '<p style="margin: 0 !important;margin-bottom:8px !important;"><img style="vertical-align:bottom;" src="'.SWL_DIR_URL.'images/'.$icon_size.'/'.$entry.'.png"/></p>';
    break;
    case "one-col-name":
    echo '<p style="margin: 0 !important;margin-bottom:8px !important;"><img style="vertical-align:bottom;margin-right:8px;" src="'.SWL_DIR_URL.'images/'.$icon_size.'/'.$entry.'.png"/>'.ucwords($entry).'</p>';
    break;
    case "two-col-noname":
    echo '<img style="vertical-align:bottom;" src="'.SWL_DIR_URL.'images/'.$icon_size.'/'.$entry.'.png"/>';
    break;
    case "two-col-name":
    echo '<img style="vertical-align:bottom;margin-right:8px;" src="'.SWL_DIR_URL.'images/'.$icon_size.'/'.$entry.'.png"/>'.ucwords($entry).'';
    break;'
    ...

    I was added a *target="_blank"* in every instruction line needed.
    Thanks for the plugin and best regards.

  4. sbglobal2013
    Member
    Posted 1 year ago #

    To force Safari to open every link in a new tab you need to use an utility you already have installed on your Mac: the Terminal. To open the Terminal open the Finder, navigate to Applications, from there into the folder Utilites.

  5. Nick
    Member
    Plugin Author

    Posted 1 year ago #

    Update to version 5.0, issue has been fixed

  6. juanstecno
    Member
    Posted 1 year ago #

    Hello,
    my social web link disappear after upgrade to version 5.0...
    I was lost all links.

  7. Nick
    Member
    Plugin Author

    Posted 1 year ago #

    Yes you will have to re-enter them through the admin page, since we changed the way they were stored.

  8. juanstecno
    Member
    Posted 1 year ago #

    Then if there is a new plugin update, should I put the links back to one to one again?

  9. Nick
    Member
    Plugin Author

    Posted 1 year ago #

    No, you had to do that because we changed the way it stored links. It was a one time thing. You won't have to enter the links again on new update

  10. juanstecno
    Member
    Posted 1 year ago #

    Hi,
    then I understand that the incidence has completely solved. Thank you very much for your support.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.