WordPress.org

Ready to get started?Download WordPress

Forums

Social
[resolved] Error 404 when tring to connect Twitter and Facebook (24 posts)

  1. herazo
    Member
    Posted 2 years ago #

    I installed Social in my blog, but when I try to set the general accounts it keeps me giving me a 404 error. This doesn´t happen when I setup the accounts for a specific user.
    What am I doing wrong?

    The path that gives me the error is this one

    http://www.xxxxxxxx.cl/wp-admin/index.php?social_controller=auth&social_action=authorize&target=https%3A%2F%2Fsopresto.mailchimp.com%2Ftwitter%2Fauthorize

    Thanks a lot if anyone can help me.

    http://wordpress.org/extend/plugins/social/

    http://wordpress.org/extend/themes/social/

  2. andyschwartz
    Member
    Posted 2 years ago #

    I have the Exact same thing. General accounts pup-up a window with the error, but profile accounts does not. Likewise, when someone clicks the sign in with buttons on the post page, it does the same thing as the general accounts sign in does.

  3. andyschwartz
    Member
    Posted 2 years ago #

    I contacted Hostgator...not sure if y9u host with them, but iit was hitting a mod_security rule on their server. They were able to release this rule on our domain.

  4. benjaminbradley
    Member
    Posted 2 years ago #

    Do you know which mod_security rule it was running up against?

  5. herazo
    Member
    Posted 2 years ago #

    Thanks a lot for the replies, I contacted Hostgator and they fixed the mod_security rule for the sites I asked. I wasn´t fast, but they did it with no objections.
    Great to count with you guys.

    Cheers
    Hugo Erazo

  6. Travis Northcutt
    Member
    Posted 2 years ago #

    Same thing here, and Hostgator got it fixed for me.

  7. tkonkel
    Member
    Posted 2 years ago #

    I couldn't figure out what was happening till I found this thread. Thanks guys. I'm also hosted on HostGator and they found the same issue with mod_security.

  8. Thea
    Member
    Posted 2 years ago #

    Me too! Glad I found this thread. Can someone be more specific about what I have to ask Hostgator to do? Will they know what Imean if I just say "please fix the mod_security"?

  9. ten80snowboarder
    Member
    Posted 2 years ago #

    Getting the same thing on a site in a HostGator reseller account.

  10. ten80snowboarder
    Member
    Posted 2 years ago #

    Just got out of an support chat with Deron S. at HostGator, he said that he had whitelisted my site in the php.ini for mod_security, but this hasn't seemed to do anything, and I'm still getting the 404 from the website.

    I'm going to see if I can get this to work, and I'll post back with any more info.

  11. Thea
    Member
    Posted 2 years ago #

    Mine has been resolved.

    Make sure you clear your cache EVERY time before you test it. I also had a support chat and it didn't work until I cleared my cache.

  12. wkeving
    Member
    Posted 2 years ago #

    For those experiencing this issue with HostGator, I was able to get resolution within a few minutes using their online chat support. Once the support rep identified the rule, he recommended that I simply ask them to whitelist mod_sec rule 340162 for the specific domain that you're working on.

    Hope this helps.

  13. peterkenne
    Member
    Posted 1 year ago #

    Problem also solved with online chat of Hostgator. Thanks guys for the info.

  14. demo38ltd
    Member
    Posted 1 year ago #

    Thanks for this - contacted Hostgator and whitelisting mod_security rule 340162 worked like a charm.

  15. rdavisphoto
    Member
    Posted 1 year ago #

    It was being blocked by a different rule for me : mod_sec rule 1234234.

    But I just sent the Hostgator Chat agent the url the command ws trying to hit and he near instantly identified and whitelisted the rule for me.

    Still, I'm annoyed at the loss of two hours chasing this. That's cost me over $1000!

  16. SurlyBird
    Member
    Posted 1 year ago #

    I had to contact my Host (idagroup, in my case) and ask them to adjust my mod_security settings, as well. I had the plugin installed correctly, but without my host adjusting the mod_security settings on the sever, I was stuck in the water. Thought it was important to share.

  17. Kirin Lin
    Member
    Posted 1 year ago #

    Problem also resolved with online chat of Hostgator. Thanks guys for the info.

  18. greg2420
    Member
    Posted 1 year ago #

    It took two rounds with Hostgator Support but they made the security whitelist updates. Social Plugin is working. TwitterTools is working. #happydance #thanks-to-all

  19. Hedley
    Member
    Posted 1 year ago #

    Okay, using the above information I was able to connect Social to FB and Twitter after I contacted Hostgator and had the rule whitelisted. That works.

    What isn't working is when a reader tries to click on "Sign in with [Twitter or Facebook]." Rather than sign in, the pop-up window simply displays my home page with this URI:

    http://www.mydomain.com/?social_controller=auth&social_action=authorize&target=https%3A%2F%2Fsopresto.mailchimp.com%2Ftwitter%2Fauthorize&post_id=1791

    I'll try talking to HostGator again about this, but has anyone experienced this separate-but-possibly-related issue? If so, was it a different mod_sec rule?

    Thanks,

    H.

  20. Hedley
    Member
    Posted 1 year ago #

    Okay, Hostgator fixed it. Just a couple of more rules that had to be whitelisted. Apparently they were:

    999022
    340594
    340162

    H.

  21. stillinbeta
    Member
    Posted 1 year ago #

    Thank you for the tip --> wkeving & Hedley

    I called HostGator and problem was fixed in 15 minutes.

  22. hledwards
    Member
    Posted 1 year ago #

    I got Hostgator to whitelist those rules, logged out of everything, restarted my browser, deleted my cache, logged back in, and got the 404 when I tried to set up Social. Then I did it all again in another browser with the same result.

    Any other suggestions? I am seconds away from finding a different plugin. Thanks.

  23. Hedley
    Member
    Posted 1 year ago #

    Rather than have HG whitelist specific rules, @hledwards, I recommend using the live chat web support. They can watch their logs as you test the fuctions that aren't working, and with luck catch whatever it causing the problem. I've found their web support pretty cooperative and helpful.

  24. uxking
    Member
    Posted 1 year ago #

    Found another workaround that didn't require me to get on the phone or chat with my host provider.

    Right click on the Sign in with Twitter, or Facebook buttons and open them in a new tab.

    You will get the 404 error, but then just add double quotes around the "https url" and click enter to load.

    For example notice the double quotes "" after the 'target=' data in the URL below:

    http://www.mydomain.com/?social_controller=auth&social_action=authorize&target="https%3A%2F%2Fsopresto.mailchimp.com%2Ftwitter%2Fauthorize"

    Hit enter after adding the double quotes and this will take you to the login page for twitter/facebook and allow you to authenticate as expected.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags