WordPress.org

Ready to get started?Download WordPress

Forums

Social Connect
[resolved] URL Rewrite (6 posts)

  1. peteranderson480
    Member
    Posted 3 years ago #

    Tried installing v.3 How do I fix the url rewrite?

    Forbidden
    You don't have permission to access /blog/wp-content/plugins/social-connect/diagnostics/test.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    http://wordpress.org/extend/plugins/social-connect/

  2. Jefferson Ryan
    Member
    Posted 3 years ago #

    This issue is caused by an mod_security rule in your installation. It's the URL present in the parameter of test.php that triggers the block.

    You may try this, to make sure that´s the problem:
    http://www.liewcf.com/how-to-disable-mod_security-in-htaccess-file-3631/

    In my case the solution above didn't worked, causing an 500 Internal Server Error. So I asked for support on my host (Hostgator) and in minutes the mod_security rule causing this was whitelisted and the plugin is now working.

    I was very disappointed with the plugin, but now that i solved this issue I think it's very promising. Social Connect does almost the same as Janrain Engage (RPX) without the need of a third party (janrain) collecting the e-mail addresses of my followers.

  3. jamisonfitz
    Member
    Posted 3 years ago #

    Thanks for the response. My host is actually Host Gator as well, I contacted chat support and they quickly solved the issue. Hopefully the notes for this plugin will be modified to let Host Gator users know they need to make this change.

  4. nicklopez4u
    Member
    Posted 3 years ago #

    Hey guys. I am actually having the same issue but my hosting provider is GoDaddy and when I called them they would not modify the .htaccess file for me due to security reasons. Can either of you post the .htaccess file code that Host Gator modified for you? I would like to see if it will solve my issue. Thanks!

  5. geodanny
    Member
    Posted 3 years ago #

    Nick, ask GoDaddy to whitelist your domain on mod_security. I've been replying to other similar questions with the following:

    There is a potential fix for 404 errors --> have your hosting provider whitelist your domain on mod_security.

    I was getting 404 errors using the diagnostic URL at the bottom of the Social-Connect config page in WP and when when using Y!, Google, and WP.com.

    For me, Y!/G/WP.com would authenticate properly and pass the user back to my web site where they then would get a 404 error. I know this because the 404 page URL would have all the data from the third party including first name, last name, and email. You can see if this is the case for you by highlighting all text in the URL and pasting into a text document.

    My hosting company is Host Gator. I use WP 3.2.1 and Social Connect 0.7.

  6. noixdarec
    Member
    Posted 2 years ago #

    GoDaddy won't whitelist our domain on mod_security for those who use shared hosting plan...

    I don't know much about all these but in my case FB & Tweeter works fine with Godaddy, and those under OpenID Providers in plugin setting (Google, Yahoo, WordPress.com) don't work.

    So dear thenbrent, for the next update could you please give us a choice to have those three using API method just like FB and Tweeter, then all of the 5 would work for those poor GoDaddy users like me.

    Best regards,

    Noixdarec

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic