WordPress.org

Ready to get started?Download WordPress

Forums

Social Connect
[resolved] Facebook login throws errors with file_get_contents (7 posts)

  1. Mike Stop Continues
    Member
    Posted 3 years ago #

    All the other services work fine, but facebook shows this upon login...

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/31/d163972550/htdocs/mikestopcontinues.com/wp-content/plugins/social-connect/social_connect.php on line 40

    Warning: file_get_contents(https://graph.facebook.com/me?access_token=) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /homepages/31/d163972550/htdocs/mikestopcontinues.com/wp-content/plugins/social-connect/social_connect.php on line 40

    http://wordpress.org/extend/plugins/social-connect/

  2. thenbrent
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Mike, you'll need to make changes to your server/php.ini config.

    Here is a good guide: http://www.unixtutorial.org/2007/09/url-file-access-is-disabled-in-the-server-configuration/

    If it doesn't help, you can find a bunch more by Googling the error message: http://www.google.com/search?&ie=UTF-8&q=URL+file-access+is+disabled+in+the+server+configuration

  3. Mike Stop Continues
    Member
    Posted 3 years ago #

    Thanks! Sorry I assumed it was the plugin. I've never encountered this error message before.

  4. DigitalOxygen.ca
    Member
    Posted 3 years ago #

    I followed the instructions on the unixtutorial site provided by thenbrent but that only removed the first of four errors. I still get the following. A bit of quick googling only turned up solutions that required modifying the php code.

    Suggestions?

    Warning: file_get_contents(https://graph.facebook.com/me?access_token=) [function.file-get-contents]: failed to open stream: HTTP request failed! HTTP/1.0 400 Bad Request in /homepages/35/d154812160/htdocs/digitaloxygen/blog/wp-content/plugins/social-connect/social-connect.php on line 72
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/35/d154812160/htdocs/digitaloxygen/blog/wp-content/plugins/social-connect/social-connect.php:72) in /homepages/35/d154812160/htdocs/digitaloxygen/blog/wp-content/plugins/social-connect/social-connect.php on line 164
    
    Warning: Cannot modify header information - headers already sent by (output started at /homepages/35/d154812160/htdocs/digitaloxygen/blog/wp-content/plugins/social-connect/social-connect.php:72) in /homepages/35/d154812160/htdocs/digitaloxygen/blog/wp-content/plugins/social-connect/social-connect.php on line 168
  5. L D
    Member
    Posted 2 years ago #

    @thenbrent, could you change this to purely CURL instead of relying on fopen?

  6. L D
    Member
    Posted 2 years ago #

  7. thenbrent
    Member
    Plugin Author

    Posted 2 years ago #

    This is fixed with L D's help in version 0.8 and newer (soon to be released).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic