WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Social Connect] Facebook Connect Error (11 posts)

  1. DrKnobz
    Member
    Posted 2 years ago #

    Social connect works fine for eveything but facebook for some reason. Here's what I get in the popup box that should be the Facebook Connect Authorization window.

    {
       "error": {
          "type": "OAuthException",
          "message": "redirect_uri isn't an absolute URI. Check RFC 3986."
       }
    }

    Any suggestions?

  2. eball218
    Member
    Posted 2 years ago #

    I too just setup a fresh install of wordpress 3.1.2 hosted on godaddy. i then precoded to install the Social Connect plugin and try it out. I get this same error when trying to use facebook. However the others work fine. any help with this would be great.

  3. ssaber
    Member
    Posted 2 years ago #

    Weird, I just noticed my Facebook connect isn't working either and I am getting the same error and it used to work fine. I also get the same error message but only when I disable one of my plugins called "Collapsing Categories" otherwise I get this one:

    {
    "error": {
    "type": "OAuthException",
    "message": "Invalid redirect_uri: Given URL is not allowed by the Application configuration."
    }
    }

  4. ouriach
    Member
    Posted 2 years ago #

    Did any of you find the answer to this? I've just come across the error.

    Thank you in advance.

  5. gjcounter
    Member
    Posted 2 years ago #

    LOL, is very easy to fix:

    Add your site url to your app settings:

    Settings->Web Site->Site URL

  6. gjcounter
    Member
    Posted 2 years ago #

    Double post, sorry.

  7. Hank22077
    Member
    Posted 2 years ago #

    I'm having this same problem.
    Funny thing is it worked yesterday, so...?

    Could this have to do with FB adding a trailing slash to url;
    while WP trims it?

  8. Hank22077
    Member
    Posted 2 years ago #

    I tried putting my url in in multiple ways, on my site as well as FB, making sure each was exactly the same. Nothing worked, thus my initial question above.

    I've found that Social Connect works, as long as I've disabled WordSocial.
    WordSocial works regardless.

    SC uses ones own API Key and App Secret;
    While WS code has the developers App ID, API Key and App Secret in the code as to allow that app to post on ur behalf.

    So, if you have both these enabled, therein lies ur problem.
    Guess I'll either try to re-code WS, or find another plugin to post to FB.

    Any other solutions...?

    Thanks

  9. redbeard2008
    Member
    Posted 2 years ago #

    today i installed Add Link to Facebook plugin my home site is on localhost server and no matter what i put as redirect url nothing is working my site url for app is
    Site URL=http://cupola.dyndns.org/CupolaNews/
    this dont work in the redirect url the only problem i get so far is this redirect_uri isn't an absolute URI. Check RFC 3986

    any help appreciated

    redbeard

  10. ineken
    Member
    Posted 2 years ago #

    Hi,

    you must to change facebook app setting. go on https://www.facebook.com/developers/apps.php

    on the right => setting/ Web site / url and site name.

    good luck :)

  11. immanence
    Member
    Posted 2 years ago #

    @Hank22077 I have the same set up as you. What were you able to work out? I really want to use WordSocial and Social Connect together. They serve different functions, but I suspect you're right about the conflict on Facebook APIs.

Topic Closed

This topic has been closed to new replies.

About this Topic