WordPress.org

Ready to get started?Download WordPress

Forums

Sociable
[resolved] Remove @socialsite (15 posts)

  1. Arpit Kumar
    Member
    Posted 2 years ago #

    I noticed that the twitter button adds text "via @socialsite" automatically. How can I remove/edit that?

    http://wordpress.org/extend/plugins/sociable/

  2. sociable
    Member
    Plugin Contributor

    Posted 2 years ago #

    hi Arpit!

    To remove (via @sociablesite) just replace /wp-content/plugins/sociable/sociable.php/ line 52

    'url' => 'http://twitter.com/intent/tweet?text=TITLE%20-%20PERMALINK%20(via%20@sociablesite)',

    to this

    'url' => 'http://twitter.com/intent/tweet?text=TITLE%20-%20PERMALINK',

    Thanks for writing us!

  3. Arpit Kumar
    Member
    Posted 2 years ago #

    Thanks for your help!

    And, many thanks for new icons and layout. Sociable Rocks!

  4. jimmyrogers
    Member
    Posted 2 years ago #

    Hi I've tried this method but this line of code doesn't seem to be on line 52 but on line 361. I changed the code anyway but the (via @sociablesite) still appears. Any ideas where I'm going wrong?

    Thanks for your help

  5. x3me88
    Member
    Posted 2 years ago #

    You have to reset Sociable in order for the changes to take effect.

  6. thegoodlifedenver
    Member
    Posted 2 years ago #

    I'm having the same issue as jimmyrogers. How do you do the plugin reset?

  7. thegoodlifedenver
    Member
    Posted 2 years ago #

    Solution found under "settings" section. Thanks.

  8. camscorner
    Member
    Posted 2 years ago #

    I the "T" Twitter icon works fine, but the one with the counter still has the via@sociablesite even after resetting and saving

  9. The_BORG
    Member
    Posted 2 years ago #

    This seems to have been changed in a newer version of the plugin. I am trying to find out how to remove it now and can not find the above info at all.

  10. Mark (podz)
    Support Maven
    Posted 2 years ago #

    The_BORG - you mean the link to Sociable? That is on the Settings page.

    To the plugin author - that link needs to default to Off please.
    Thanks

  11. The_BORG
    Member
    Posted 2 years ago #

    Not the link, but when you hit either Twitter button... I don't the the "via @sociablesite" or #sociablesite in my tweets. I want the tweets to have "@The_BORG" instead.

  12. Mark (podz)
    Support Maven
    Posted 2 years ago #

    The file socialable.php is what you want.

    When I open it the contents are weirdly formatted and this is on line 14389
    'url' => 'http://twitter.com/intent/tweet?text=TITLE%20-%20PERMALINK%20(via%20@sociablesite)',

    Try opening that file in Notepad or textedit and search for @sociable which should find it.

    'url' => 'http://twitter.com/intent tweet?text=TITLE%20-%20PERMALINK%20(via%20@The_BORG)',

    should work.

  13. The_BORG
    Member
    Posted 2 years ago #

    Thanks for the info Mark, but I've searched for "@sociablesite" and every variation of the code people say where it should be. It's not there. There's no "permalink", no "intent", etc...

    Maybe this is something new in their latest version that was updated a few days ago?

  14. theonetruebix
    Member
    Posted 2 years ago #

    There's really no way to disable or configure this without having to edit the plugin code, which will then be overwritten whenever there's an upgrade?

  15. cloudslam
    Member
    Posted 2 years ago #

    Do what x3me88 said.
    Here's how you should do it to get rid of this socialsite/blogplay stuff:

    1) Remove all unwanted text or replace it with your own. It could be just sociable.php file or more like sociable_output.php etc. (use
    grep -R 'sociablesite' ./*
    to locate all occurrences).
    Save your changes.

    2) Go to WP back-end > Sociable Options and record all your settings (so you can restore it later)

    3) Hit the 'Reset Sociable' button.

    4) Restore your settings back.

    The text should be gone now, at least on twitter, I didn't check it with Facebook - don't really care.

    Disclaimer: You'll need to repeat this procedure after each upgrade of Sociable plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags