WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Sociable] Plugin breaks site validation (6 posts)

  1. Morgaine
    Member
    Posted 6 years ago #

    Unfortunately this plugin breaks site validation, because & is used instead of & in some urls (in sociable.php), more specifically those for ‘e-mail’, ‘SalesMarks’, ‘Webnews.de’ and ‘Yigg’. Could you please change this in a next version?

    http://wordpress.org/extend/plugins/sociable/

  2. Joost de Valk
    Member
    Posted 6 years ago #

    Fixed in 2.6.4 :) thx for noticing!

  3. realepicurean
    Member
    Posted 6 years ago #

    I'd had to make that tweak in sociable.php a while ago, too. Still a great plugin though.

  4. Morgaine
    Member
    Posted 5 years ago #

    In the latest version of Sociable, the above described error has reappeared, for Ratimarks. It breaks validation, so I changed it manually, but perhaps you can fix this in a next release?

  5. Morgaine
    Member
    Posted 5 years ago #

    Another problem, when using XHTML 1.0 Strict as one's doctype, is line 696 of sociable.php

    I changed

    echo '<script language="JavaScript" type="text/javascript" src="' . $sociablepluginpath . 'wists.js"></script>'."\n";

    into

    echo '<script type="text/javascript" src="' . $sociablepluginpath . 'wists.js"></script>'."\n";

    in order to have my site validate.

  6. ddeconin
    Member
    Posted 5 years ago #

    When I run xhtml validation on my site I get
    ' Line 230, Column 21: document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag.
    <div class="sociable">'
    for the code in my index.php
    <?php if (function_exists('sociable_html')) { echo sociable_html(); } ?>
    Were you able to fix that ?

Topic Closed

This topic has been closed to new replies.

About this Topic