WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Sociable] Nothing Displayed (20 posts)

  1. bradykelly
    Member
    Posted 5 years ago #

    I've just added Sociable, and it seems to be 'hooked' in properly, and I have set the default to include on all posts and pages, and I have selected a few sites, but nothing shows on my blog. What now?

  2. peapodsquadmom
    Member
    Posted 5 years ago #

    i'm having the same problem. maybe someone will come to the rescue here.

  3. knox-it-avenger
    Member
    Posted 4 years ago #

    I also am having this problem not showing up anywhere in my posts.

  4. frank93
    Member
    Posted 4 years ago #

    same here: upgraded from 3.3.7 (?) to 3.4.3 and suddenly there aren't any icons anymore, as if sociable was deactivated. i didn't change anything in the theme-template though, single.php still contains the call for sociable_html(); and sociable IS activated in the plugin-settings.

    help? :)

  5. michaelroop
    Member
    Posted 4 years ago #

    I noticed that the icons had disappeared on the pages where they normally appeared. If I go to the sociableoff custom field I have to remove the 'false' from value and leave it blank. Then the icons will appear.

    This had shown the icons with 'false' before. I will hold off changing anything for now.

  6. michaelroop
    Member
    Posted 4 years ago #

    Actually, if I just click on update for the page (without changing anything) the false disappears and the icons can be seen on the page.

    Another thing that I noticed is that the Sociable disabled check box then becomes checked and there is nothing that I can do to uncheck it. If I try to uncheck it, the next time I click on Update page it gets checked again.

  7. hel1701
    Member
    Posted 4 years ago #

    In the later version (3.4.x that I can see) there's a checkbox for "Sociable Off" that seems to default to checked. Uncheck box, save, stuff works.

    I don't know if it's a glitch or intentional that it defaults to disabled. Since I can't find a global reactivation button (and the code implies that it should be "false", I'm rolling back.

  8. Tyler Hayes
    Member
    Posted 4 years ago #

    Same problem here, except I don't have the old plugin file so I can't rollback. I started experiencing this problem with the most recent update as well.

  9. hel1701
    Member
    Posted 4 years ago #

    The WordPress codex holds all committed versions. Uninstall the current version first and grab whatever one you want to try from here -> http://wordpress.org/extend/plugins/sociable/download/

    I'm using one from the early 3.3 series without issue.

  10. circlecube
    Member
    Posted 4 years ago #

    Thanks for the help, rollback successful for me too!

  11. Mossack Anme
    Member
    Posted 4 years ago #

    This way is too much difficult, but I succeded to resolve the problem.

    1. Download Sociable 3.4.3 pack.
    2. Extract, then open sociable.php.
    3. Edit code in line 898. Erase "checked" code.
    from
    <input type="checkbox" id="sociableoff" name="sociableoff" <?php checked($sociableoff); ?>/> <label for="sociableoff"><?php _e('Sociable disabled?','sociable') ?></label>
    to
    <input type="checkbox" id="sociableoff" name="sociableoff" <?php ($sociableoff); ?>/> <label for="sociableoff"><?php _e('Sociable disabled?','sociable') ?></label>
    4. Upload them to your Sociable plugins folder.
    5. Finally, this is the longest way, update all of your post. This way make me boring.
    6. Enjoy Sociable 3.4.3.

    Regards,
    MossackAnmeâ„¢

  12. Mossack Anme
    Member
    Posted 4 years ago #

    beuh,,rollback seems easier to do... (-.-')

    Thx hel1701...

    Regards,
    MossackAnmeâ„¢ Blog

  13. Mark / t31os
    Moderator
    Posted 4 years ago #

    Try this update around the same lines you mentioned before..

    Find this..

    function sociable_meta() {
    	global $post;
    	$sociableoff = false;
    	$sociableoffmeta = get_post_meta($post->ID,'sociableoff',true);
    	if ($sociableoffmeta == "true" || $sociableoffmeta == true) {
    		$sociableoff = true;
    	}
    	?>
    	<input type="checkbox" id="sociableoff" name="sociableoff" <?php checked($sociableoff); ?>/> <label for="sociableoff"><?php _e('Sociable disabled?','sociable') ?></label>
    	<?php
    }

    Change for..

    function sociable_meta( $sociableoff = false ) {
    	global $post;
    	$sociableoffmeta = get_post_meta($post->ID,'sociableoff',true);
    	// If $socialoffmeta doesn't exist, it's false already..
    	if($sociableoffmeta) {
    		// We're only here if it's true
    		switch($sociableoffmeta) {
    			// Make the case matching for turning off via field a little friendlier
    			case 'true':
    			case 'off':
    			case 'yes':
    			$sociableoff = true;
    			break;
    			// Catch space and empty value fields
    			case '':
    			case ' ':
    			default:
    			$sociableoff = false;
    			break;
    		}
    	}
    	?>
    	<input type="checkbox" id="sociableoff" name="sociableoff" <?php checked($sociableoff); ?>/> <label for="sociableoff"><?php _e('Sociable disabled?','sociable') ?></label>
    	<?php
    }

    Doe that help at all?

  14. Nehemoth
    Member
    Posted 4 years ago #

    Same problem here.

    I did both what mossackanme & t31os_ said, which didn't work.

    So I did a rollback, I guess the problem is when the plugin insert the code into the theme for be displayed, I guess is not working anymore for some reason.

  15. Mark / t31os
    Moderator
    Posted 4 years ago #

    Pretty sure (although i don't use it), it's due to the $socialoff variable...

    That's why i posted a change above...

    I think the author has made some changes to standard behaviour.

    It doesn't look (as in - from what i can see) that there is any problem with the code per say... just that there are different default behaviours...

    Code posted was to try and help resolve, obviously it didn't... :(

    It's pretty useless me posting code for the most part anyway, if the author doesn't know about the problem, this will carry across versions..

    The best thing you can do is report this to the author so he can include fixes in the next version, else you'll be doing modificaions with every upgrade...

  16. Joost de Valk
    Member
    Posted 4 years ago #

    Ok almost have a working solution for this that has the added benefit of being about 10 times faster. There's one issue: it's not backwards compatible, this means that you'll have to go through the pages where you want to have sociable disabled and set it disabled again, for one time...

  17. Joost de Valk
    Member
    Posted 4 years ago #

    The latest upgrade should fix this issue, should be available in about 15 minutes after posting this.

  18. Mark / t31os
    Moderator
    Posted 4 years ago #

    :) Nice one.. :)

    What was the problem, if you don't mind me asking, was i close or totally off the mark? (lol)..

  19. Joost de Valk
    Member
    Posted 4 years ago #

    too much bad code around it, check how it's done now, that's about 20 times easier. One of the issues was the meta didn't have the _ in front of it, which caused it to appear in "custom fields" on the edit post screen as well, which caused double saves and all sorts of errors related to that...

  20. hel1701
    Member
    Posted 4 years ago #

    3.4.4 Works perfectly, thanks for the fix!

Topic Closed

This topic has been closed to new replies.

About this Topic