WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Sociable] Image map completely off... (22 posts)

  1. nathanbrauer
    Member
    Posted 4 years ago #

    Please see any of my posts from http://nathanbrauer.com to see what I mean. (I'd post a screenshot but my IP has been blacklisted from my own host and I haven't fixed it yet.)

  2. nathanbrauer
    Member
    Posted 4 years ago #

    Here's a screenshot:
    http://bit.ly/RCXss

  3. nathanbrauer
    Member
    Posted 4 years ago #

    (and why does this thread say I posted just 1 day ago? I posted this about 3 or 4 days ago!)

  4. digitalPimple
    Member
    Posted 4 years ago #

    I have an issue like this too. I upgraded 3.5.1 and now my admin seems not to be in a table and the icons run vertically on my posts instead of horizontally.

    Take a look:
    http://www.digitalPimple.com

  5. nathanbrauer
    Member
    Posted 4 years ago #

    I don't see it installed on your site at all. Can you post a direct link?

  6. nathanbrauer
    Member
    Posted 4 years ago #

    I've disabled sprites in order to temporarily fix it, so you won't see it directly at my site. Please refer to this screenshot to see what the problem is: http://bit.ly/RCXss

    Even with sprites enabled, it should work.

  7. digitalPimple
    Member
    Posted 4 years ago #

    I turned it off Its back on now

  8. nathanbrauer
    Member
    Posted 4 years ago #

    Ah I see.

    Mkay so my site has logged about 50+ people visiting it from here and 27 people visiting the screenshot.... and no one has any feedback for either of us yet?

  9. digitalPimple
    Member
    Posted 4 years ago #

    Nope. Pretty Lame.

  10. lafhaha
    Member
    Posted 4 years ago #

    I'm having the exact same problem and it looks horrid. :( Can anyone please post a fix or some help for this?

  11. lafhaha
    Member
    Posted 4 years ago #

    Alright. I got it. For future reference...If you see the above image map problem on your icons, check the "Disable sprite usage" box in the sociable's admin and it should go back to normal.

    <3

  12. nathanbrauer
    Member
    Posted 4 years ago #

    But it should still work without disabling sprites....

  13. sociable
    Member
    Posted 4 years ago #

    The sprite that comes with the plugin includes the 16x16px version of the icons.
    For using custom icons you should disable sprite usage and set up your custom icons.

  14. nathanbrauer
    Member
    Posted 4 years ago #

    But I don't have any custom icons at all -- I'm running a bare install.

  15. astromono
    Member
    Posted 4 years ago #

    Same thing here, the image map on my icons seems moved or like the image isn't the right size. You can check any individual post at http://www.astromono.com to see what I mean.

    Any chance we can get help from the plugin developer?

  16. sociable
    Member
    Posted 4 years ago #

    Nathanbrauer / astromono: if you change the icon's size on the stylesheet you should switch off sprite usage. The icons included in it are 16x16px fixed.

  17. xerxy
    Member
    Posted 4 years ago #

    Having the same issue with my icons since 3.5.1 (now upgraded to 3.5.2). I didn't change the icon size or try anything funny. Sample here:

    jetpack powered by water/

    With the last upgrade, I fixed it by modifying sociable.php and changing the icon offsets slightly to get the full icon to display. Don't feel like doing that again.

    Oh, and it happens in both Firefox and Opera.

  18. sociable
    Member
    Posted 4 years ago #

    xerxy: The link area is longer than 16x16, that's why you're seeing part of other services icons. You should check your CSS. Regards.

  19. sociable
    Member
    Posted 4 years ago #

    xerxy: There's a 2px padding defined on your stylesheet (style.css line 100).

  20. astromono
    Member
    Posted 4 years ago #

    @sociable: Thank you very much for the reply!

    I checked on your advice to xerxy and was able to fix the issue by putting this simple rule in my main stylesheet:

    .sociable a img {padding: 0;}

    It just takes off any padding from image links belonging exclusively to the sociable class. I'm using an external sheet tho, but I think it will work if you put it in the one that comes with the plugin.

    Hope this helps!

  21. nathanbrauer
    Member
    Posted 4 years ago #

    Sociable should be able to work out of the box without edits to my theme. I didn't "change the icon's size" in my CSS. It was just like that.

  22. xerxy
    Member
    Posted 4 years ago #

    D'oh. Thanks sociable. I should have checked my own css.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags