WordPress.org

Ready to get started?Download WordPress

Forums

Sociable for WordPress 3.0
[resolved] Share URLs seem scrambled (4 posts)

  1. gholt
    Member
    Posted 3 years ago #

    Awesome plugin. I was using an older version and just deactived it and installed this new version for WP 3.0.

    I have the same sort of problem on posting to facebook or any of the icons I hover over (probably a board setting and not the plugin):

    http://www.facebook.com/share.php?u=http%3A%2F%2Fwww.gekholt.com%2Flifegroup%2F2010%2F07%2F09%2F11-jul-2010-lesson%2F&t=11%20Jul%202010%20Lesson

    looks like I'm getting a %2F instead of a /

    The facebook post looks like this for the share:

    11 Jul 2010 Lesson | FBC Lifegroup
    http://www.gekholt.com/lifegroup/2010/07...
    PDRTJS_settings_2293991_post_66 = {
    "id" : "2293991",
    "unique_id" : "wp-post-66",
    "title" : "11+Jul+2010+Lesson",
    "item_id" : "_post_66",
    "permalink" : "http%3A%2F%2Fwww.gekholt.com%2Flifegroup%2F2010%2F07%2F09%2F11-jul-2010-lesson%2F"
    }

    Lesson Outline: RedeemedforRelationship07111010

    one other thing, WordPress changed your plugin page directory so if you are in Plugins and you click on "Visit plugin site" it tries to go to:
    http://wordpress.org/extend/plugins/sociable3 should it be: http://wordpress.org/tags/sociable-30 ?

    Thanks again for the killer plugin and taking the time to support.

  2. tompokress
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, thanks for bringing this to my attention. The URL is "url encoded" so the %2F and so on are normal.

    I think what's making the FaceBook share look weird is that your star ratings plugin is embedding some javascript ("PDRTJS_settings...") in the post content.

    As a workaround could you create an excerpt for the post (the plugin will submit that instead of the content), or try a different ratings plugin?

    If others folks have this problem, though, I'll look into stripping <script> tags out before the post is shared.

  3. gholt
    Member
    Posted 3 years ago #

    tompokress, yeap it looks like PollDaddy was giving me the problem. What is weird is my other posts posted to Facebook fine, but apparently when PollDaddy has it's settings set on Posts, Enable for blog posts it adds that PDRTJS stuff to the link.

    It's apparently a PollDaddy problem like you said and I know it's something they need to fix. Since PollDaddy only allows 100 responses a month before they charge money (it's quite a bit for a personal blog) I'll probably save myself the headache and switch to another poll...two strikes rule.

    Did you check out:
    one other thing, WordPress changed your plugin page directory so if you are in Plugins and you click on "Visit plugin site" it tries to go to:
    http://wordpress.org/extend/plugins/sociable3 should it be: http://wordpress.org/tags/sociable-30 ?

    Thanks

  4. tompokress
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    I never did figure out plugin home page thing...oh well, thanks for letting me know though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic