WordPress.org

Ready to get started?Download WordPress

Forums

Sociable
Error - do not have sufficient permissions (10 posts)

  1. webjim
    Member
    Posted 3 years ago #

    I have installed Sociable, and I can't select new sites from the admin without getting the error:

    do not have sufficient permissions

    I have changed all the permissions to 777 via ftp, and I don't really know what to do next.

    Thanks for the help.

    Jim

  2. webjim
    Member
    Posted 3 years ago #

    I sent this to my host/tech support:

    I had to actually have my host do something on their end to resolve one problem.

    They had to make changes to their PHP server and now the plugin update on the full plugin menu works.

    No luck.

  3. webjim
    Member
    Posted 3 years ago #

    Now I just sent them this suggestion:

    For those who get this error randomly, without having upgraded WordPress recently, it’s caused by a database table being corrupted. Log in to MySQL and perform a repair using the syntax
    repair table tablename
    This fixed mine the first time I tried it.

  4. webjim
    Member
    Posted 3 years ago #

    The response from my host:

    Hi,

    Can you try again, I repaired the database.

    Thanks,
    Chris

    Still not fixed...

    Does anybody have anymore suggestions?

    Thanks,

    Jim

  5. webjim
    Member
    Posted 3 years ago #

    Now I am trying this:

    4) Opened up Plesk – used Database WebAdmin to bring up PHPMyAdmin

    5) Click on the User_Meta Table
    6) Made sure table prefixes were consistent and correct

    7) Saw that I now had an extra line in user_meta named ‘capabilities’ instead of ‘wp_capabilites’ and the value was “subscriber”

    Copied long string of information with wp_capabilities that WP put there on the initial instal to the meta_value for the line listed ‘capabilities’ and this changed the permissions from subscriber to administrator.

    10) After all this was complete. Everything showed up in working order in my admin panel.

    I will let you know if it fixes the problem...

  6. webjim
    Member
    Posted 3 years ago #

    Nobody has any suggestions?

  7. webjim
    Member
    Posted 3 years ago #

    I just uninstalled the plug-in and reinstalled it via ftp in binary mode.

    That didn't fix it either...

  8. webjim
    Member
    Posted 3 years ago #

    Now I am suggesting this to my host:

    NO .HTACCESS FILE?
    If you’re receiving an permissions error, you may also want to check that you have .htaccess in your main WordPress directory. This can also sometimes cause you problems.

  9. webjim
    Member
    Posted 3 years ago #

    This was tried....no luck

    IF YOU DO NOT HAVE an .htaccess in your wp-admin/ directory:

    create a text file on your desktop:

    put the following inside it:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save the file. name it whatever you want

    Upload the file to your wp-admin directory.

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    Edit it, and add the following:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    save the new .htaccess

  10. webjim
    Member
    Posted 3 years ago #

    I finally got it figured out:

    One of the tech guys at my hosting facility:

    Hey Jim,

    I needed to disable the mod_security apache module. It views the way the wordpress code works as insecure apparently.

    Thanks,

    No more warning messages now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags