WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Sociable] 3.5.1 Released (14 posts)

  1. sociable
    Member
    Posted 4 years ago #

    We released a fix for version 3.5

    Changelog:

    - fixed the xhtml validation issues
    - 'target=blank' issue solved
    - sprites can now be disabled, allowing for custom icons
    - sprites have been disabled for RSS
    - you can now deactivate the blogplay widget from your wordpress dashboard

    We loved the feedback, please keep it coming!

  2. hal_robertson
    Member
    Posted 4 years ago #

    hello thank you for the update

    everything else seems to be working fine, except the "email" icon has a weird border around it

    I'm trying to debug. Any ideas? It appears to be the only icon with a problem.

  3. Nyhm
    Member
    Posted 4 years ago #

    My theme adds a border around images, which I don't want for Sociable links. I always hack sociable.css like so:

    .sociable img {
    	float: none;
    	width: 16px;
    	height: 16px;
    	border: 0 !important;
    	margin: 0 !important;
    	padding: 0 !important;
    	background: none !important;
    }

    Could this be added as a standard feature? I don't see why theme image style should ever apply to Sociable icons. (But the background tag might break the new CSS Sprite technique... I had to disable it.)

  4. Gary Pendergast
    Member
    Posted 4 years ago #

    This upgrade doesn't seem to fix the XHTML validation issues:

    http://validator.w3.org/check?uri=http://pento.net/&ss=1

  5. sociable
    Member
    Posted 4 years ago #

    @pento you are trying to validate it in HTML 5, it is validated for XHTML transitional. We will deal with the duplicate IDs in the upcoming versions

  6. Gary Pendergast
    Member
    Posted 4 years ago #

    Unique ID values is defined in HTML4, and every subsequent HTML and XHTML spec. I'm not sure how you're validating it in your tests, but your tests are evidently broken. Duplicate IDs have never been allowed.

    Also, I'd appreciate it if you changed the line:

    wp_enqueue_style('sociable-front-css',$sociablepluginpath.'sociable.css');

    to:

    wp_enqueue_style('sociable-front-css',$sociablepluginpath.'sociable.css', false, false, 'all');

    The media attribute really shouldn't be left empty, or at the very least, should be set to 'all'.

  7. Bernhard Kau
    Member
    Posted 4 years ago #

    @sociable: Thanks for the fast update of your great plugin.

    The plugin is now almost (x)html valid. You just have to remove line 777 which adds an ID to the images. The ID is not neccessary for the stylesheets or the javascript so why have you used it?

    When I remove the line your plugin works as before. So could you please remove the line in the next update so we don't have to do that manually. Or is there a hidden miracle with the ID I didn't see?

  8. Secure-IT
    Member
    Posted 4 years ago #

    I think this sounds like a reason for v3.5.2 for XHTML validation issues.

    I'm glad to hear that you now made the dashboard widget able to be removed. I'm just not a fan of push-on marketing.

    :-)

    Haha, one other thing, I just noticed in this forum posting you specified the WordPress version as being "WordPress version: 3.5.1". I wish I had access to WordPress 3.5 haha. Guess I'll have to settle for v2.8.4 still. Oh well.

  9. Navjot Singh
    Member
    Posted 4 years ago #

    Why DesignFloat has been removed? Its completely live service now.

  10. digitalPimple
    Member
    Posted 4 years ago #

    Sociable was working great at 3.5 on 2.8.4 but after upgrade a whole mess.

    Posts: The icons all align vertically now.

    Live blog at: http://www.digitalPimple.com

  11. digitalPimple
    Member
    Posted 4 years ago #

    Also I can no longer drag and drop the icons to reorder them in my admin area. They display just as the icons in my post do.. One long vertical list.

  12. titanad
    Member
    Posted 4 years ago #

    Since the 3.5.1 update, I can NO LONGER access the Sociable plugins' settings page. It only comes up as a blank page.

    HR

  13. digitalPimple
    Member
    Posted 4 years ago #

    What happened to this great plugin. I would love to use it but can not the way it is.

  14. KZeni
    Member
    Posted 4 years ago #

    @pento I'm validating for HTML5 and I just want to thank you for posting that.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags